Bug 1311995 - Web-UI:rbac:Clicking on Users or Groups with restricted role user throws "undefined method `where' for #<Array:0x000000057a2510> [ops/tree_select]" error.
Web-UI:rbac:Clicking on Users or Groups with restricted role user throws "und...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity medium
: GA
: 5.5.3
Assigned To: Harpreet Kataria
Milan Falešník
rbac:ui:error
: ZStream
Depends On: 1311399
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-25 08:13 EST by John Prause
Modified: 2017-08-29 21:35 EDT (History)
9 users (show)

See Also:
Fixed In Version: 5.5.3.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1311399
Environment:
Last Closed: 2016-04-13 14:44:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 CFME Bot 2016-02-26 15:12:12 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=f91c73d4b6720192c64dd6c16efae9c123b46bd4

commit f91c73d4b6720192c64dd6c16efae9c123b46bd4
Merge: e2c7013 65c45b4
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Fri Feb 26 14:52:15 2016 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Fri Feb 26 14:52:15 2016 -0500

    Merge branch '55z_bz_1311995' into '5.5.z'
    
    Fix list of group and user with self_service user
    
    Self service user means that user's role has option
    "VM & Template Access Restriction" set up to "Only User Owned" or
    "Only User or Group Owned"
    (cherry picked from commit 978efcb)
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1311995
    https://bugzilla.redhat.com/show_bug.cgi?id=1311399
    
    @dclarizi please review, this is cherry pick of commit 978efcbb50a5a80a303146ba19aa669ed42d607c from https://github.com/ManageIQ/manageiq/pull/6437
    
    See merge request !816

 app/models/rbac.rb | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)
Comment 5 Milan Falešník 2016-03-29 11:37:18 EDT
Verified in 5.5.3.2, no error happens when logging in as such created user.
Comment 7 errata-xmlrpc 2016-04-13 14:44:53 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0616

Note You need to log in before you can comment on or make changes to this bug.