Bug 1312004 - Failed to update Smart Class Parameter type from API and CLI.
Failed to update Smart Class Parameter type from API and CLI.
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity medium (vote)
: Beta
: --
Assigned To: orabin
Jitendra Yejare
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks: 1278718
  Show dependency treegraph
 
Reported: 2016-02-25 08:48 EST by Jitendra Yejare
Modified: 2016-07-27 05:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:02:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 13899 None None None 2016-04-22 12:01 EDT

  None (edit)
Description Jitendra Yejare 2016-02-25 08:48:02 EST
Description of problem:
I am unable to update smart class parameter type from API from any to any.

Version-Release number of selected component (if applicable):
foreman-1.11.0-0.develop.201602171602gitd5b5059.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1. Update smart class parameter type from API from any type to any other type.

#curl-X PUT -H "Content-Type: application/json" -d '{"parameter_type":"string"}' "https://<server_url>/api/smart_class_parameters/<param_id>" --insecure

Actual results:
Parameter Type is not updated.

Output:
"description":"","override":true,"parameter_type":"boolean","default_value":true,"hidden_value?":false,"hidden_value":"*****","use_puppet_default":false,"required":true,"validator_type":"","validator_rule":null,"merge_overrides":null,"merge_default":false,"avoid_duplicates":null,"override_value_order":"fqdn\nhostgroup\nos\ndomain","override_values_count":0,"created_at":"2016-02-25 12:07:30 UTC","updated_at":"2016-02-25 13:45:20 UTC","puppetclass_name":"nova::api","parameter":"admin_password","id":322,"puppetclass_id":37,"environments":[{"id":3,"name":"KT_Default_Organization_Dev_puppet_cv_3"},{"id":2,"name":"KT_Default_Organization_Library_puppet_cv_3"}],"puppetclass":{"id":37,"name":"nova::api","module_name":"nova"},"override_values":[]}

Expected results:
Parameter should be updated.

Additional info:
Comment 1 Jitendra Yejare 2016-02-25 08:55:19 EST
The issue is also observed from CLI.

The output says 'Parameter Updated.' but not actually updated.

Steps:
1. Update smart class parameter type from CLI from any type to any other type.

Actual Behavior:
The output says 'Parameter Updated.' but not actually updated.
Output:
[root@qeblade36 ~]# hammer sc-param update --parameter-type string --id 322
Parameter updated


Expected Behavior:
Parameter Type has to be updated.
Comment 2 Jitendra Yejare 2016-02-25 08:56:54 EST
Created redmine issue http://projects.theforeman.org/issues/13899 from this bug
Comment 4 Bryan Kearney 2016-02-28 12:09:40 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/13899 has been closed
-------------
Ori Rabin
Applied in changeset commit:6bab9b5b96ad059abddd7d51460a277cf2c160f9.
Comment 5 Jitendra Yejare 2016-02-29 07:03:03 EST
Confirming that This bug has been verified in upstream on date 29th Feb 2016.
Comment 6 Jitendra Yejare 2016-03-23 07:44:17 EDT
Verified in Sat 6.2 snap 4.

The issue is no more reproducible.

I can update the parameter type from any to any type from both CLI as well as API successfully.

Moving the bug to Verified.
Comment 9 errata-xmlrpc 2016-07-27 05:02:23 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500

Note You need to log in before you can comment on or make changes to this bug.