Bug 1312008 - [RFE] Create a armrest log for debug output for enhanced troubleshooting.
[RFE] Create a armrest log for debug output for enhanced troubleshooting.
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.5.0
All All
high Severity medium
: GA
: 5.6.0
Assigned To: Daniel Berger
Jeff Teehan
azure:maintenance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-25 08:58 EST by Josh Carter
Modified: 2016-06-29 11:39 EDT (History)
3 users (show)

See Also:
Fixed In Version: 5.6.0.1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:39:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh Carter 2016-02-25 08:58:31 EST
1. Proposed title of this feature request  
      
Create a armrest log for debug output for enhanced troubleshooting. 
      
    2. Who is the customer behind the request?  
    Account: Red Hat Global Support Services
      
    TAM customer: yes  
    SRM customer: yes  
    Strategic: yes  
      
    3. What is the nature and description of the request?  

Create a log for the azure-armrest gem so that debug can be enabled to enhanced troubleshooting when diagnosing azure provider issues. 
      
    4. Why does the customer need this? ease of support 
      
    5. How would the customer like to achieve this? (List the functional requirements here)  
      
    6. For each functional requirement listed, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented.  
      
    7. Is there already an existing RFE upstream or in Red Hat Bugzilla?  
      
    8. Does the customer have any specific timeline dependencies and which release would they like to target (i.e. RHEL5, RHEL6)?  
      
    9. Is the sales team involved in this request and do they have any additional input?  
      
    10. List any affected packages or components.  
      
    11. Would the customer be able to assist in testing this functionality if implemented?
Comment 2 Daniel Berger 2016-02-25 11:08:24 EST
The azure-armrest gem uses the rest-client gem internally, and that has some baked in logging support that you can use by setting your RESTCLIENT_LOG environment variable. That can point to a file, or to an IO stream (stdout, etc).

The output includes the requests being made, and the contents of each request.
Comment 3 Daniel Berger 2016-04-04 08:51:02 EDT
As of azure-armrest 0.2.4, you can now call Azure::ArmrestService.log and Azure::ArmrestService.log= to set a log file to either a file name or a file handle.

You may still also set the RESTCLIENT_LOG environment variable, though it must be set before loading the azure-armrest gem to get picked up.
Comment 4 Jeff Teehan 2016-04-20 14:02:22 EDT
Moving to verified for 5.6 Beta 1 using https://10.16.7.174/vm_cloud/explorer
Comment 6 errata-xmlrpc 2016-06-29 11:39:45 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.