Bug 1312018 - [systemd] Make changes to start opal-prd daemon automatically (fedora-release)
[systemd] Make changes to start opal-prd daemon automatically (fedora-release)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: fedora-release (Show other bugs)
24
ppc64le Linux
unspecified Severity high
: ---
: ---
Assigned To: Stephen Gallagher
Fedora Extras Quality Assurance
: Reopened
Depends On: 1284527
Blocks: PPCTracker F-ExcludeArch-ppc64le/PPC64LETracker 1312446
  Show dependency treegraph
 
Reported: 2016-02-25 09:26 EST by Vasant Hegde
Modified: 2016-06-16 13:41 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-16 13:41:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 137829 None None None 2016-02-25 09:53 EST

  None (edit)
Description Vasant Hegde 2016-02-25 09:26:45 EST
Description of problem:
  We have new package opal-prd which contains "OPAL Processor Recovery Diagnostics daemon" (#1284527). This is ppc64le specific package. We want to start daemon automatically.


Please include this daemon in 90-systemd.preset script.


Vasant
Comment 1 IBM Bug Proxy 2016-02-25 11:17:18 EST
------- Comment From hannsj_uhl@de.ibm.com 2016-02-25 10:46 EDT-------
.
Comment 2 Jason McDonald 2016-02-26 03:58:36 EST
This bug has been incorrectly added to the "Edit Fedora Components" group, which should not be used for bugs.  As it is not clear whether this bug is intended to be public or private, I'm going to add the bug to the Fedora Contrib Private group so that the other group can be removed from this bug and disabled.

If it's ok for the bug to be public, the Fedora Contrib Private group can be cleared.
Comment 3 Vasant Hegde 2016-02-26 04:18:57 EST
(In reply to Jason McDonald from comment #2)
> This bug has been incorrectly added to the "Edit Fedora Components" group,
> which should not be used for bugs. 

Sorry. That was my mistake.


> As it is not clear whether this bug is
> intended to be public or private, I'm going to add the bug to the Fedora
> Contrib Private group so that the other group can be removed from this bug
> and disabled.

I'm fine to keep it under Private group.

-Vasant
Comment 4 Jan Synacek 2016-02-26 06:53:58 EST
If you want your service to be enabled by default, see https://fedoraproject.org/wiki/Packaging:DefaultServices, section "Approved Exceptions".

Feel free to reopen this bugzilla when you have the necessary exception approved.
Comment 5 Vasant Hegde 2016-03-03 07:47:00 EST
I've raised https://fedorahosted.org/fesco/ticket/1558 to get exception approval from FESCO.

-Vasant
Comment 6 Vasant Hegde 2016-03-04 01:34:01 EST
As disu(In reply to Vasant Hegde from comment #5)
> I've raised https://fedorahosted.org/fesco/ticket/1558 to get exception
> approval from FESCO.

As suggested by sgallagh in above ticket I'm REOPENING this bug and changing component to fedora-release.

-Vasant
Comment 7 Stephen Gallagher 2016-03-04 09:06:00 EST
(In reply to Vasant Hegde from comment #6)
> As disu(In reply to Vasant Hegde from comment #5)
> > I've raised https://fedorahosted.org/fesco/ticket/1558 to get exception
> > approval from FESCO.
> 
> As suggested by sgallagh in above ticket I'm REOPENING this bug and changing
> component to fedora-release.
> 
> -Vasant

Thanks. Can you please specify the exact systemd units that you want enabled by default? e.g. foo.service, bar.socket or baz.timer
Comment 8 Vasant Hegde 2016-03-06 23:40:46 EST
(In reply to Stephen Gallagher from comment #7)
> (In reply to Vasant Hegde from comment #6)
> > As disu(In reply to Vasant Hegde from comment #5)
> > > I've raised https://fedorahosted.org/fesco/ticket/1558 to get exception
> > > approval from FESCO.
> > 
> > As suggested by sgallagh in above ticket I'm REOPENING this bug and changing
> > component to fedora-release.
> > 
> > -Vasant

Stephen,

> 
> Thanks. Can you please specify the exact systemd units that you want enabled
> by default? e.g. foo.service, bar.socket or baz.timer

Exact service name is :  opal-prd.service

-Vasant
Comment 9 Zbigniew Jędrzejewski-Szmek 2016-03-07 07:10:51 EST
What about the socket unit?
Comment 10 Vasant Hegde 2016-03-07 07:58:51 EST
(In reply to Zbigniew Jędrzejewski-Szmek from comment #9)
> What about the socket unit?

opal-prd.socket

-Vasant
Comment 11 Zbigniew Jędrzejewski-Szmek 2016-03-07 09:42:33 EST
Sure, I know what the socket is called. My question (implicit, but I thought it would be obvious) is whether you want it enabled by default, and if yes why, and if no, why not.

And if yes, why do you want the service started by default instead of being socket activated.
Comment 12 Vasant Hegde 2016-03-11 00:41:27 EST
(In reply to Zbigniew Jędrzejewski-Szmek from comment #11)
> Sure, I know what the socket is called. My question (implicit, but I thought
> it would be obvious) is whether you want it enabled by default, and if yes
> why, and if no, why not.

Yes. We want to enable this by default.

opal-prd daemon handles hardware-specific recovery processes, and should be run as a background system process after boot. It interacts with OPAL firmware to capture hardware error causes, log events to the management processor, and handles recoverable errors where suitable. Without this daemon we will not be able to handle hardware errors (like processor checkstop). Hence we would like to enable this daemon by default on ppc64le architecture. 

> 
> And if yes, why do you want the service started by default instead of being
> socket activated.

No particular reason. Either way works for me as long as daemon starts by default.


-Vasant
Comment 13 Zbigniew Jędrzejewski-Szmek 2016-03-11 07:51:42 EST
OK, after looking at the two unit files, .service Requires the .socket unit, so it is enough to only put the .service in presets.
Comment 14 Vasant Hegde 2016-03-14 00:36:24 EDT
(In reply to Zbigniew Jędrzejewski-Szmek from comment #13)
> OK, after looking at the two unit files, .service Requires the .socket unit,
> so it is enough to only put the .service in presets.

Thanks!

-Vasant
Comment 16 Vasant Hegde 2016-03-28 00:32:26 EDT
Looks like its fixed in rawhide branch.. But not yet included in Fedora24 branch.


changelog from rawhide branch.

fedora-release-25-0.7.noarch.rpm
* Fri Mar 18 2016 Dennis Gilmor <dennis@ausil.us> - 25-0.7
- drop Requires(post): sed
- Fork to execute systemctl calls

* Tue Mar 15 2016 Dennis Gilmore <dennis@ausil.us> - 25-0.6
- Properly handle systemd presets in Lua scripts
- enable opal-prd.service
- Remove call to grub2-mkconfig


-Vasant
Comment 17 Dennis Gilmore 2016-03-28 10:49:32 EDT
It was not pulled into f24 yet as we were in alpha freeze and it did not fix anything that was proposed as a blocker or freeze exception. As such it was inappropriate to pull in.
Comment 18 Mike McCune 2016-03-28 19:33:48 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 19 Peter Robinson 2016-05-16 07:26:53 EDT
This will be in fedora-release-24-0.18 (or the next one)
Comment 20 Vasant Hegde 2016-06-16 12:56:47 EDT
Verified on fedora-release-24-1.noarch.rpm and its fixed.
We can close this bug.

-Vasant

Note You need to log in before you can comment on or make changes to this bug.