Bug 1312021 - [abrt] dnf: ascii.py:26:decode:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc5 in position 13: ordinal not in range(128)
[abrt] dnf: ascii.py:26:decode:UnicodeDecodeError: 'ascii' codec can't decode...
Status: CLOSED DUPLICATE of bug 1308994
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:52039a6fd3abb28003432cb0018...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-25 09:29 EST by Miro Hrončok
Modified: 2016-02-25 09:31 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-25 09:31:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: _var_log_dnf.log (262.07 KB, text/plain)
2016-02-25 09:29 EST, Miro Hrončok
no flags Details
File: backtrace (2.00 KB, text/plain)
2016-02-25 09:29 EST, Miro Hrončok
no flags Details
File: dnf-makecache.log (243.57 KB, text/plain)
2016-02-25 09:29 EST, Miro Hrončok
no flags Details
File: environ (1.90 KB, text/plain)
2016-02-25 09:29 EST, Miro Hrončok
no flags Details

  None (edit)
Description Miro Hrončok 2016-02-25 09:29:27 EST
Description of problem:
Will mark this as duplicite t bug where this was described

Version-Release number of selected component:
dnf-1.1.6-2.fc23

Additional info:
reporter:       libreport-2.6.4
cmdline:        /usr/bin/python3 /bin/dnf install './Sta\xc5\xbeen\xc3\xa9/nosync-1.0-3.fc23.i686.rpm'
executable:     /bin/dnf
kernel:         4.3.5-300.fc23.x86_64
runlevel:       N 5
type:           Python3
uid:            0

Truncated backtrace:
ascii.py:26:decode:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc5 in position 13: ordinal not in range(128)

Traceback (most recent call last):
  File "/bin/dnf", line 57, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 174, in user_main
    errcode = main(args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 60, in main
    return _main(base, args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 120, in _main
    ret = resolving(cli, base)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 149, in resolving
    base.do_transaction(display=displays)
  File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 228, in do_transaction
    super(BaseCli, self).do_transaction(display)
  File "/usr/lib/python3.4/site-packages/dnf/base.py", line 612, in do_transaction
    self._run_transaction(cb=cb)
  File "/usr/lib/python3.4/site-packages/dnf/base.py", line 734, in _run_transaction
    self.verify_transaction(cb.verify_tsi_package)
  File "/usr/lib/python3.4/site-packages/dnf/base.py", line 832, in verify_transaction
    self.history.sync_alldb(po)
  File "/usr/lib/python3.4/site-packages/dnf/yum/history.py", line 1403, in sync_alldb
    self._save_yumdb(ipkg)):
  File "/usr/lib/python3.4/site-packages/dnf/yum/history.py", line 1375, in _save_yumdb
    val = yumdb_info.get(attr)
  File "/usr/lib/python3.4/site-packages/dnf/yum/rpmsack.py", line 338, in get
    res = self._read(attr)
  File "/usr/lib/python3.4/site-packages/dnf/yum/rpmsack.py", line 268, in _read
    value = fo.read()
  File "/usr/lib64/python3.4/encodings/ascii.py", line 26, in decode
    return codecs.ascii_decode(input, self.errors)[0]
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc5 in position 13: ordinal not in range(128)

Local variables in innermost frame:
self: <encodings.ascii.IncrementalDecoder object at 0x7fec40fbfdd8>
input: b'install ./Sta\xc5\xbeen\xc3\xa9/nosync-1.0-3.fc23.i686.rpm'
final: True
Comment 1 Miro Hrončok 2016-02-25 09:29:37 EST
Created attachment 1130560 [details]
File: _var_log_dnf.log
Comment 2 Miro Hrončok 2016-02-25 09:29:38 EST
Created attachment 1130561 [details]
File: backtrace
Comment 3 Miro Hrončok 2016-02-25 09:29:41 EST
Created attachment 1130562 [details]
File: dnf-makecache.log
Comment 4 Miro Hrončok 2016-02-25 09:29:43 EST
Created attachment 1130563 [details]
File: environ
Comment 5 Miro Hrončok 2016-02-25 09:31:03 EST

*** This bug has been marked as a duplicate of bug 1308994 ***

Note You need to log in before you can comment on or make changes to this bug.