Bug 1312040 - Pacemaker used with CMAN should not ship ocf:pacemaker:controld RA
Pacemaker used with CMAN should not ship ocf:pacemaker:controld RA
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pacemaker (Show other bugs)
6.8
Unspecified Unspecified
low Severity low
: rc
: 6.9
Assigned To: Ken Gaillot
cluster-qe@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-25 10:27 EST by Jan Pokorný
Modified: 2017-03-21 05:51 EDT (History)
4 users (show)

See Also:
Fixed In Version: pacemaker-1.1.15-1.el6
Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-21 05:51:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pokorný 2016-02-25 10:27:48 EST
As it is too late to try change anything such late in the game
as the initscripts had already started dlm_controld by the time
Pacemaker is started.

Users should not be misled to think that agent is of any use
in Pacemaker + CMAN scenario.

At least this was one of the observations that arose from one of
the internal discussions (take it with a grain of salt for now).
Comment 1 Jan Pokorný 2016-05-24 17:46:26 EDT
I was trying to reconsider whether this is a good idea or not.

Why it is a good idea to drop this from Pacemaker-CMAN orchestra:

1. /etc/init.d/cman start/stops both {dlm,gfs}_controld automatically,
   so it should(?) work just as predestined in ocf:pacemaker:controld
   agent (globally unique clones)

2. agent uses "-s 0" as a default option, and this is not recognized
   by RHEL 6 dlm version:
# dlm_controld -V
> dlm_controld 3.0.12.1 (built Feb  1 2016 07:06:27)
> Copyright (C) Red Hat, Inc.  2004-2010  All rights reserved.
# dlm_controld -s 0
> dlm_controld: invalid option -- 's'
> Please use '-h' for usage.

3. even if start and monitor actions might work well out of the box,
   it's unclear if Pacemaker-triggered stop action would be acceptable
   under all circumstances (note that dlm_controld is started before
   gfs_controld and they are stopped in reverse order in cman initscript)


Plus consider a subtle character of DLM/Pacemaker integration (not sure
if that affects CMAN/fenced as well):
[bug 1268313]
https://github.com/ClusterLabs/pacemaker/pull/839
Comment 2 Ken Gaillot 2016-05-24 18:02:51 EDT
It does make sense to remove it. In RHEL 6, the CMAN init script manages dlm_controld, so it should not be managed as a cluster resource.
Comment 7 michal novacek 2017-01-13 10:17:40 EST
I have verified that ocf:pacemaker:controld is not part of pacemaker rpm in pacemaker-1.1.15-4

before the fix pacemaker-1.1.15-3.el6.x86_64
============================================

# rpm -ql paceamker | grep controld
/usr/lib/ocf/resource.d/pacemaker/controld
/usr/share/man/man7/ocf_pacemaker_controld.7.gz
#

after the fix pacemaker-1.1.15-3.el6.x86_64
===========================================
# rpm -ql paceamker | grep controld
#
Comment 9 errata-xmlrpc 2017-03-21 05:51:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2017-0629.html

Note You need to log in before you can comment on or make changes to this bug.