Bug 1312054 - Incremental publish does not remove old updateinfo.xml file from repodata.
Incremental publish does not remove old updateinfo.xml file from repodata.
Status: CLOSED DUPLICATE of bug 1307207
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Pulp (Show other bugs)
6.1.6
x86_64 Linux
low Severity low (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-25 10:59 EST by rakesh kumar
Modified: 2017-07-26 15:40 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-05 14:44:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Pulp Redmine 1045 Low CLOSED - DUPLICATE incremental publish does not remove old updateinfo.xml 2016-08-03 10:31 EDT

  None (edit)
Description rakesh kumar 2016-02-25 10:59:16 EST
Description of problem:
When an incremental publish is performed the old updateinfo.xml is not removed if a checksum is specified. Each publish adds a new updateinfo, which has a different checksum.


Version-Release number of selected component (if applicable): 
Red Hat Satellite 6.1.6


How reproducible:
Always


Steps to Reproduce:
1. Create a content view, add jbiss(or any other) repository in it.
2. Publish the content view multiple times.
3. list the file at below path:
# ls /var/lib/pulp/published/yum/https/repos/Optum/DevOPS_DEV/RHEL_6_DevOps/content/dist/rhel/server/6/6Server/x86_64/ose-jbosseap/2.2/os/repodata
# ls -l
total 264
-rw-r--r--. 1 apache apache  2346 Jan 14 16:01 2cf247f29a1dc33a29af24293d93141d8d46297c-primary.xml.gz
-rw-r--r--. 1 apache apache   130 Jan 14 16:01 406ca46e811cbb67669659067e496c49a203ebc8-comps.xml
-rw-r--r--. 1 apache apache 46888 Jan 14 16:01 52ef78bec08868bbb36bf5f84e1d84a061c44bab-updateinfo.xml.gz
-rw-r--r--. 1 apache apache 45273 Dec 16 21:47 562d74ed45c8f83838a9554479b1b02ee33aa4c5-updateinfo.xml.gz
-rw-r--r--. 1 apache apache 45273 Dec 16 00:47 bc119e6791c365bff44e0bc9acc7a8bf71326f5a-updateinfo.xml.gz
-rw-r--r--. 1 apache apache  3141 Jan 14 16:01 bdd8ec449465f576766b64b5c704b1853c52246a-other.xml.gz
-rw-r--r--. 1 apache apache 46888 Dec 23 12:54 d992f23dacd8163eda26c7216fb1962474e7fd98-updateinfo.xml.gz

Actual results:
Multiple updateinfo.xml.gz file in repodata.

Expected results:
Single updateinfo.xml.gz file in repodata.


Additional info:
The upstream bug can be found at https://pulp.plan.io/issues/1045.
Comment 1 Bryan Kearney 2016-07-26 15:03:25 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 3 pulp-infra@redhat.com 2016-08-03 10:31:33 EDT
The Pulp upstream bug status is at CLOSED - DUPLICATE. Updating the external tracker on this bug.
Comment 4 pulp-infra@redhat.com 2016-08-03 10:31:36 EDT
The Pulp upstream bug priority is at Low. Updating the external tracker on this bug.
Comment 5 pulp-infra@redhat.com 2016-11-21 16:01:12 EST
The Pulp upstream bug status is at NEW. Updating the external tracker on this bug.
Comment 6 pulp-infra@redhat.com 2016-11-21 16:01:15 EST
The Pulp upstream bug priority is at Normal. Updating the external tracker on this bug.
Comment 7 Michael Hrivnak 2016-12-05 14:44:15 EST

*** This bug has been marked as a duplicate of bug 1307207 ***

Note You need to log in before you can comment on or make changes to this bug.