Bug 1312057 - python error in rtevalConfig.py
Summary: python error in rtevalConfig.py
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rteval
Version: 7.3
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: rc
: 7.3
Assignee: Clark Williams
QA Contact: Jiri Kastner
Maxim Svistunov
URL:
Whiteboard:
Keywords:
: 1418811 (view as bug list)
Depends On:
Blocks: 1274397 1353018
TreeView+ depends on / blocked
 
Reported: 2016-02-25 16:04 UTC by Brian Brock
Modified: 2017-03-21 00:06 UTC (History)
7 users (show)

(edit)
*python* errors no longer appear when `SUDO_USER` and `USER` variables are not set

Previously, when executing in spare environments that do not have `SUDO_USER` or `USER` environment variables set, a number of *python* errors appeared. With this update, undefined `SUDO_USER` and `USER` variables are handled correctly, and the errors no longer appear.
Clone Of:
(edit)
Last Closed: 2016-11-04 01:34:39 UTC


Attachments (Terms of Use)
patch to handle sparse environment in hwcert test suite (1.54 KB, patch)
2016-04-14 00:05 UTC, Clark Williams
no flags Details | Diff
local function to return string value when determining user name (1.30 KB, patch)
2016-09-20 14:02 UTC, Clark Williams
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2244 normal SHIPPED_LIVE rteval bug fix and enhancement update 2016-11-03 13:29:41 UTC

Description Brian Brock 2016-02-25 16:04:47 UTC
Description of problem:
The hwcert realtime test fails with a python traceback:
TypeError: cannot concatenate 'str' and 'NoneType' objects




Version-Release number of selected component (if applicable):
redhat-certification-2.3-20160223.el7.noarch
redhat-certification-hardware-1.7.1-20160210.el7.noarch



How reproducible:
realiably on at least one test system

Steps to Reproduce:
1. run the hwcert realtime test
2. check logs or debug output
3.

Actual results:
crash with traceback:

  File "/usr/lib/python2.7/site-packages/rhcert/client/harness.py", line 573, in _doRun
    returnValue = self.runTest(logDirectory, testDocument, runDocument, outputFilePath)
  File "/usr/lib/python2.7/site-packages/rhcert/client/harness.py", line 1001, in runTest
    rv = test.run()
  File "/usr/lib/python2.7/site-packages/rhcert/suites/hwcert/tests/realtime/realtime.py", line 101, in run
    from rteval import RTEVAL_VERSION
  File "/usr/lib/python2.7/site-packages/rteval/__init__.py", line 37, in <module>
    from modules.loads import LoadModules
  File "/usr/lib/python2.7/site-packages/rteval/modules/__init__.py", line 26, in <module>
    from rteval.rtevalConfig import rtevalCfgSection
  File "/usr/lib/python2.7/site-packages/rteval/rtevalConfig.py", line 82, in <module>
    'srcdir'     : default_config_search(['loadsource']),
  File "/usr/lib/python2.7/site-packages/rteval/rtevalConfig.py", line 41, in default_config_search
    (os.getenv('SUDO_USER') or os.getenv('USER'))), '.rteval'),
TypeError: cannot concatenate 'str' and 'NoneType' objects



Expected results:
test runs to completion and succeeds

Additional info:

Comment 1 Clark Williams 2016-04-14 00:05 UTC
Created attachment 1146993 [details]
patch to handle sparse environment in hwcert test suite

Comment 2 Clark Williams 2016-04-14 00:06:43 UTC
Note, the above patch will go into rteval-2.8

Comment 3 Clark Williams 2016-04-28 18:27:52 UTC
Added to rteval build 2.8

Comment 6 Clark Williams 2016-09-20 14:02 UTC
Created attachment 1202917 [details]
local function to return string value when determining user name

Comment 7 Clark Williams 2016-09-20 14:04:33 UTC
The above patch adds the local function get_user_name() which handles empty environment variables SUDO_USER and USER. This patch modifies the original patch and will be available in the next build of rteval (2.12).

Comment 10 errata-xmlrpc 2016-11-04 01:34:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2244.html

Comment 11 John Kacur 2017-03-21 00:06:23 UTC
*** Bug 1418811 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.