Bug 131206 - Installer doesn't recognize i2o disks
Installer doesn't recognize i2o disks
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-29 17:46 EDT by Harry Hoffman
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-30 11:32:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harry Hoffman 2004-08-29 17:46:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040803

Description of problem:
Fedora Core 2 installer does not show disks connected to an i2o
controller (in this case a adaptec 3200S SCSI RAID card).

The i2o modules seem to load fine but there is no entry in the /dev
directory for any of the disks
(i.e.-> /dev/i2o/hd[a-z])

Furthermore, once the install is complete and the system has been
rebooted the disks can be seen by the system.
(i.e. -> /dev/i2o/hd[a-f])

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install FC2 onto a system with disks attached to a i2o controller
2. Attempt to partition the disks attached to the i2o controller
    

Actual Results:  None of the disks attached to the i2o controller were
available to be partitioned.

Expected Results:  disks attached to the i2o controller should have
shown up in Disk Druid so that they were available to be partitioned.

Additional info:

I was not using the hardware RAID feature of this controller but
rather attempting to address the individual disks.
Comment 1 Jeremy Katz 2004-08-30 11:32:31 EDT
i2o disks aren't supported for installation with FC2.  The kernel
didn't really export enough information for me to be able to probe them.
Comment 2 dijuremo 2004-10-21 07:59:57 EDT
THIS IS ABSURD!!!. I2O devices were supported under Fedora Core 1.  So
newer versions of Fedora loose hardware support?. Every other
distribution I have tried supports the I2O devices.  Shall we choose a
different distribution?.

Diego Remolina
Comment 3 Paul Nasrat 2004-10-21 08:07:05 EDT
Fedora Core 1 was 2.4 not 2.6, what kernel versions were the "other 
distributions".  

This bug is for FC2 which as Jeremy says there wasn't enough exposed
information:

The current i20 support is described here:

http://i2o.shadowconnect.com/fedora.php

FC2 Howto:

http://www.redhat.com/archives/fedora-list/2004-May/msg03906.html

Faq:

http://i2o.shadowconnect.com/faq.php
Comment 4 dijuremo 2004-10-21 13:24:24 EDT
Well,

FC3 Test 3 handles I2O correctly, so I will wait to install the system
using FC3 when it gets release status (hopefully a couple of weeks
more at most).  The "other distributions"  I tried where gentoo and
knoppix using the 2.6.7 kernel.

I also noticed other distros handle i2o devices as /dev/sda* and that
Fedora Core 3 does /dev/i2o/hda.  Is there any special kernel
modification on the FC3 kernel for i2o devices?

Diego

Comment 5 dijuremo 2004-10-22 07:11:32 EDT
The Howto on:

http://www.redhat.com/archives/fedora-list/2004-May/msg03906.html

... works like a charm.  So there is really support to install I2O
devices with FC2 if you get the missing module and add it.

From the link above:

"
1) Unpack the kernel RPM for your FC2 installer. 32bit is the "i586"
kernel, and 64bit is the "x86_64" kernel. Use a command like:

rpm2cpio kernel-2.6.5-1.358.i586.rpm | cpio -idv

NOTE: Use the i586 kernel and NOT the i686.

2) Take the i2o_proc.ko module and put it on a web server somewhere.

3) At the first screen of isolinux, use "expert askmethod" as a boot
option. Do any network install where you manage to get online.

4) When it asks if you want to load any driver disks, go into ALT-F2
terminal and wget the module into /tmp. Use insmod to load that module
and lsmod to verify that it was loaded.

NOTE:  insmod -p /tmp i2o_proc.ko

5) Go back into Anaconda and go through the next few screens. Disk
Druid should now see the i2o disks. Everything *SHOULD* work now. At
least it did for us in testing.

6) After installation you wont ever need the i2o_proc module again,
and it should *JUST WORK*. If not report your results here and I will
try to help.
"

Diego

Note You need to log in before you can comment on or make changes to this bug.