Bug 1312092 - crmd can crash after unexpected remote connection takeover
crmd can crash after unexpected remote connection takeover
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pacemaker (Show other bugs)
6.7
All All
high Severity medium
: rc
: 6.8
Assigned To: Ken Gaillot
cluster-qe@redhat.com
:
Depends On: 1252206
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-25 12:33 EST by Ken Gaillot
Modified: 2016-05-10 19:52 EDT (History)
2 users (show)

See Also:
Fixed In Version: pacemaker-1.1.14-3.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1312094 (view as bug list)
Environment:
Last Closed: 2016-05-10 19:52:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Cluster Labs 5269 None None None 2016-02-25 12:33 EST

  None (edit)
Description Ken Gaillot 2016-02-25 12:33:33 EST
Description of problem: An attempted connection to a Pacemaker Remote node that already is integrated into a cluster will disconnect the node from the cluster, and the cluster host's crmd may print garbled log messages and/or crash.


Version-Release number of selected component (if applicable):


How reproducible: easily/consistently


Steps to Reproduce:
1. Configure a Pacemaker cluster including a Pacemaker Remote node.
2. Start the cluster and wait for the remote node to integrate.
3. From any machine with access to the Pacemaker Remote port, run "nc -t <nodename> 3121".

Actual results: Remote node will be disconnected from the cluster, its monitor operation will fail, and the cluster node hosting its connection may have crmd crash or print log messages with random characters.


Expected results: The attempted connection fails, and the cluster is unaffected.
Comment 2 Ken Gaillot 2016-02-25 12:42:28 EST
This was fixed upstream as of 5ec24a2, and the necessary patches were included in the latest build for #1252206. This BZ was added for tracking and QA purposes.
Comment 7 errata-xmlrpc 2016-05-10 19:52:58 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0856.html

Note You need to log in before you can comment on or make changes to this bug.