Bug 1312107 - updating a host's facet should not require the facet id to be included in facet params
updating a host's facet should not require the facet id to be included in fac...
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high (vote)
: Beta
: --
Assigned To: Shimon Shtein
jcallaha
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-25 13:23 EST by Justin Sherrill
Modified: 2016-07-27 05:02 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:02:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 13849 None None None 2016-04-22 12:18 EDT

  None (edit)
Description Justin Sherrill 2016-02-25 13:23:31 EST
Instead of requiring an update to a host's facet attributes to include the ID of the facet, look up the needed ID in the API controller and add to params. Facet IDs are not, imho, a user-facing aspect that needs to be exposed.


<pre>
{
    host_id: 123,
    host: {
        name: "abc.example.com",
        content_facet_attributes: {
            id: 1234,    <---- REMOVE
            lifecycle_environment_id: 12,
            content_view_id: 12
        },
        subscription_facet_attributes: {
            id: 1234,    <---- REMOVE
            service_level: "Premium"
         }
    }
}
</pre>
Comment 1 Justin Sherrill 2016-02-25 13:23:33 EST
Created from redmine issue http://projects.theforeman.org/issues/13849
Comment 3 Bryan Kearney 2016-02-29 12:02:50 EST
Upstream bug assigned to sshtein@redhat.com
Comment 4 Bryan Kearney 2016-03-09 12:03:03 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/13849 has been closed
-------------
Shimon Shtein
Applied in changeset commit:ec76b0092f9af5b8f7e2e02777f376b6b6e0d711.
Comment 6 jcallaha 2016-04-04 15:32:35 EDT
Verified in Satellite 6.2 Beta Snap 6 Compose 1.

Behavior now is as expected.
Comment 8 errata-xmlrpc 2016-07-27 05:02:27 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500

Note You need to log in before you can comment on or make changes to this bug.