Bug 1312110 - document that speed measurement uses cpu user time and document -elapsed option
document that speed measurement uses cpu user time and document -elapsed option
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: openssl (Show other bugs)
7.2
All Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Tomas Mraz
Hubert Kario
: Documentation
Depends On: 1197095
Blocks: 1197099
  Show dependency treegraph
 
Reported: 2016-02-25 13:35 EST by Hubert Kario
Modified: 2016-11-03 22:05 EDT (History)
3 users (show)

See Also:
Fixed In Version: openssl-1.0.1e-56.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1197095
Environment:
Last Closed: 2016-11-03 22:05:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2271 normal SHIPPED_LIVE openssl bug fix and enhancement update 2016-11-03 09:34:37 EDT

  None (edit)
Description Hubert Kario 2016-02-25 13:35:19 EST
Issue not fixed in openssl-1.0.1e-51.el7_2.2.x86_64. Marking as regression since the issue will  be fixed in RHEL-6.8.0 release

Description of problem:
When measuring algorithms' speed while using engine ibmca, results are wildly inaccurate, because number of operations is divided by the ammount of processor time used, which is very low for external engine.

Version-Release number of selected component (if applicable):
openssl-ibmca-1.2.0-4.el6.s390x
openssl-1.0.1e-30.el6_6.5.s390x

How reproducible:
always

Steps to Reproduce:
1. openssl speed -engine ibmca rsa512

Actual results:
engine "ibmca" set.
Doing 512 bit private rsa's for 10s: 4015 512 bit private RSA's in 0.02s
Doing 512 bit public rsa's for 10s: 4336 512 bit public RSA's in 0.03s
OpenSSL 1.0.1e-fips 11 Feb 2013
built on: Tue Jan 13 08:38:01 EST 2015
options:bn(64,64) md2(int) rc4(8x,char) des(idx,cisc,16,int) aes(partial) idea(int) blowfish(idx)
compiler: gcc -fPIC -DOPENSSL_PIC -DZLIB -DOPENSSL_THREADS -D_REENTRANT -DDSO_DLFCN -DHAVE_DLFCN_H -DKRB5_MIT -m64 -DB_ENDIAN -DTERMIO -Wall -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -march=z9-109 -mtune=z10 -Wa,--noexecstack -DPURIFY -DOPENSSL_BN_ASM_MONT -DOPENSSL_BN_ASM_GF2m -DSHA1_ASM -DSHA256_ASM -DSHA512_ASM -DAES_ASM -DAES_CTR_ASM -DAES_XTS_ASM -DGHASH_ASM
                 sign    verify    sign/s verify/s
rsa 512 bits 0.000005s 0.000007s 200750.0 144533.3

Expected results: (cca)
...
                 sign    verify    sign/s verify/s
rsa 512 bits 0.002490s 0.002306s    401.5    433.6

--- Additional comment from Tomas Mraz on 2015-02-27 09:22:18 EST ---

There is actually already -elapsed option that implements this request however it is undocumented.
Does it work for you?
Comment 9 errata-xmlrpc 2016-11-03 22:05:47 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2271.html

Note You need to log in before you can comment on or make changes to this bug.