Bug 131213 - [chinput] aux object should be destroyed when application closes
Summary: [chinput] aux object should be destroyed when application closes
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: im-sdk   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Yu Shao
QA Contact:
URL:
Whiteboard:
Keywords: i18n
Depends On:
Blocks: FC3Target IIIMF FC4Target 137149
TreeView+ depends on / blocked
 
Reported: 2004-08-30 02:33 UTC by Lawrence Lim
Modified: 2014-03-26 00:50 UTC (History)
3 users (show)

Fixed In Version: 0.3-11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-19 06:42:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Lawrence Lim 2004-08-30 02:33:38 UTC
Description of problem:
In the GNOME environment, when application closes, the AUX object for
the LE still remains visible. Is it possible to remove the AUX object
when an application closes.

Version-Release number of selected component (if applicable):
- im-sdk-12.0.1-1
- iiimf-le-chinput-0.3-5

How reproducible:
Always

Steps to Reproduce:
1.select zh_CN locale and GNOME session at gdm
2.start gnome-terminal
3.toggle on LE
4.close gnome-terminal by clicking (x) button
  
Actual results:
AUX object remains in the desktop environment

Expected results:
AUX object should be removed.

Additional info:

Comment 1 Yu Shao 2004-09-07 04:54:02 UTC
I can't reproduce it with iiimf-server-11.4-66.svn1772, can someone
else test it with earlier version a little bit?

Comment 2 Lawrence Lim 2004-09-07 05:44:44 UTC
Can you reproduce it in im-sdk-12.0 onwards?
I do have older version of im-sdk. If you like I can pass it to you.




Comment 3 Lawrence Lim 2004-09-07 08:38:52 UTC
My apologies. Did not understand what you meant earlier. Will do a
test on a version between 11.4-66 and 12.0.1 to find out when the
problem starts to emerge.

Comment 4 Lawrence Lim 2004-09-14 07:44:35 UTC
Tested with 11.4-70.svn1856 and iiimf-le-chinput-0.3-6, the problem
still exist. Will try again with -68 perhaps.

Comment 5 Akira TAGOH 2004-09-15 00:57:13 UTC
it's just FYI:
First, right now IIIMF do nothing because chinput doesn't call
iml_aux_done_inst().
IMO the location of realizing/destroying the aux object is probably:
1) where the IM is activated/deactivated, like my_conversion_on/off()
    PROBLEM: as you know, it makes slow starting the applications.
maybe you need to fix the aux object to speed up.
2) where the session is created/destroyed, like you already did and on
DestroySC to call aux_done.
    PROBLEM: since the trigger of DestroySC is from the client side
and when it's came from the client side, IIIMCF handle is also
destroyed. so LEs can't do anything for that on DestroySC so that the
session on the client side was disconnected.

although maybe both issues should be fixed, 2) looks hard to fix.

Comment 6 Lawrence Lim 2004-09-15 02:18:22 UTC
Tested with 11.4-68.svn1833 and  iiimf-le-chinput-0.3-6, the problem
still exist.

Comment 7 Lawrence Lim 2004-09-15 02:27:00 UTC
Tested with 11.4-65.svn1804 and iiimf-le-chinput-0.3-6, the problem
still exist.

Comment 8 Lawrence Lim 2004-09-15 02:43:26 UTC
Tested with 11.4-66.svn1833 and iiimf-le-chinput-0.3-6, the problem
still exist. 

I noticed that the version -66 you used has a different svn number.
Maybe you could send me your im-sdk package and I can have a look again.

Thanks.

Comment 9 Akira TAGOH 2004-10-06 14:15:25 UTC
could you please destroy the aux object itself if the aux object isn't
used anymore as the summary says it?
even if all of window was closed, the aux object process still remains.

tagoh    22386 22322  0 23:14 ?        00:00:00 com.redhat.chinput.status


Comment 10 Warren Togami 2004-10-13 08:45:41 UTC
Reproduce Procedure:
1) Right-Click gimlet -> Preferences
2) Set "use the language currently selected in Quick Access menu"
3) Use cannaLE Japanese
4) Focus in a gtk2 app
5) CTRL-Shift-Space and change to Simplified Chinese
6) CTRL-Shift-Space and change to Japanese

Result:
chinput's auxmenu does not destroy, despite Japanese being the active
LE.  Changing focus to other apps does not make auxmenu go away.  Only
thing that makes it go away is if you switch back to Simplified Chinese.

Comment 11 Lawrence Lim 2004-10-19 10:35:37 UTC
Tested with im-sdk-12.1-1 on x86_64 machine, the problem still exist
after LE if toggle off.

llim      4470  1.1  0.6 96208 6584 pts/2    S+   20:35   0:00
com.redhat.chinput.status


Comment 12 Lawrence Lim 2004-11-09 05:24:08 UTC
The aux menu now gets destroyed after I click the (x) button on
application. But I need to check if the process is still there. Moving
to QA queue.


Thanks.

Comment 13 Lawrence Lim 2004-11-10 05:21:03 UTC
Tested im-sdk-12.1-6 with iiimf-le-chinput-0.3-13, closing the
application using the (x) button does remove the aux from the screen.
However, the process is still running.

root      7318  0.7  2.4 23164 6132 pts/1    S    15:20   0:00
com.redhat.chinput.status


Comment 14 Yu Shao 2004-11-19 06:42:49 UTC
Set it to UPSTREAM, casue right now, hide the aux window is the best
solution so far. 

Comment 15 Akira TAGOH 2004-11-22 07:03:20 UTC
Aren't you upstream for iiimf-le-chinput? and do you have any bug
tracker for? :) Why I've changed this summary is to avoid the upgrade
problem. right now when people is upgrading LEs, older aux object is
used as long as it's running. IMHO restarting the desktop or so after
upgrading is a bug. I don't think hiding the aux window is *best* anyway.


Note You need to log in before you can comment on or make changes to this bug.