This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1312135 - timezone.py defaults to LOCAL time when using a kickstart file where timezone is not specified
timezone.py defaults to LOCAL time when using a kickstart file where timezone...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.2
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Martin Kolman
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-25 15:25 EST by William Skupa
Modified: 2016-11-03 19:22 EDT (History)
3 users (show)

See Also:
Fixed In Version: anaconda-21.48.22.78-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 19:22:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Skupa 2016-02-25 15:25:34 EST
Description of problem:
Kickstarting an install with Timezone not specified and instead selected from the GUI, causes the resulting system time to be off by the timezone selected offset because the hwclock and adjtime are set to LOCAL.

Removing the check for flags.automatedInstall from timezone.py corrects the issue

Version-Release number of selected component (if applicable):
anaconda 21.48.22.56-1

How reproducible:
100%

Steps to Reproduce:
1. Create a kickstart file for a fully automated install, except don't specify timezone or root's password 
2. Install system using kickstart file
3. After install verify time is now LOCAL by running:
    cat /mnt/sysimage/etc/adjtime

Actual results:
Installed system has the wrong time and is using LOCAL time

Expected results:
Installed system has the correct time and is using UTC time


Additional info:
Comment 2 Martin Kolman 2016-05-31 11:09:54 EDT
I think this is actually the correct behavior and it has been like this at least since RHEL 5 - if you do a kickstart installation and want the hwclock to be considered in UTC you need to use the --utc option:

RHEL 5: https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/5/html/Installation_Guide/s1-kickstart2-options.html
RHEL 6: https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/Installation_Guide/s1-kickstart2-options.html
RHEL 7: https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/Installation_Guide/sect-kickstart-syntax.html

Of that does not really cover the case where you install with partial kickstart and want the user to set the timezone manually while assuming the hwclock is in UTC.

Maybe making it possible to just use "timezone --utc" without a timezone would work ? It would still ask the user to set the timezone but assume the hwclock is in UTC.
Comment 6 Marek Hruscak 2016-08-24 12:53:25 EDT
Option timezone --utc without specific timezone is now able to use to instruct anaconda to use UTC instead of LOCAL.
Comment 8 errata-xmlrpc 2016-11-03 19:22:39 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2158.html

Note You need to log in before you can comment on or make changes to this bug.