Bug 131214 - Cannot spawn any more xterms
Cannot spawn any more xterms
Status: CLOSED DUPLICATE of bug 128154
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-29 23:36 EDT by George Toft
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description George Toft 2004-08-29 23:36:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; X11; Linux i686) Opera 
7.51  [en]

Description of problem:
See bug 128154

Similarity is that I have several xterms open.  I followed advice in 
above bug, including killing off process holding pty/0.  I have not 
upgraded the kernel as this is the FC3T1 distro.

Main difference is that killing off the process that is holding pty/0 
allows me to spawn only 1 more xterm - no net gain.

Other differences - the time before this condition appears ranges 
from an hour to a week, not the 24 hours or so mentioned in the above 
bug.  As this system is being tuned and adjusted, it gets rebooted, 
so it has not been up more than a week - actual time to failure may 
be longer.

Reboot circumvents the problem.

Version-Release number of selected component (if applicable):
2.6.7-1.478

How reproducible:
Sometimes

Steps to Reproduce:
1.  Spawn an xterm
2.  When conditions are right, CPU load climbs, then drops off.  No 
xterm appears.

    

Actual Results:  No xterm appears

Expected Results:  xterm should appear

Additional info:
Comment 1 Warren Togami 2004-08-30 01:01:21 EDT
I'm pretty sure this is a duplicate of 128154, which seems to be fixed
with the latest rawhide kernels.  If you don't want to upgrade to
rawhide, see if it works properly in FC3 test2.

*** This bug has been marked as a duplicate of 128154 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:05:21 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.