This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1312144 - Ceph logs to emerg
Ceph logs to emerg
Status: CLOSED DUPLICATE of bug 1276186
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RADOS (Show other bugs)
1.3.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 1.3.3
Assigned To: Samuel Just
ceph-qe-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-25 16:10 EST by Chris St. Pierre
Modified: 2017-07-30 11:11 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-25 17:35:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris St. Pierre 2016-02-25 16:10:33 EST
Description of problem:

http://tracker.ceph.com/issues/13993

Version-Release number of selected component (if applicable):

$ rpm -qa ceph\*
ceph-common-0.94.3-3.el7cp.x86_64
ceph-mon-0.94.3-3.el7cp.x86_64
ceph-0.94.3-3.el7cp.x86_64

How reproducible:

Always

Steps to Reproduce:

1. Enable ceph logging to syslog

Actual results:

Get spammed with update_stats messages on wall:

Broadcast message from systemd-journald@mcp-02-rhel-7.localdomain (Thu 2016-02-25 21:09:12 UTC):

ceph-mon[9435]: 2016-02-25 21:09:12.471679 7fa0d79d1700  0 mon.mcp-02-rhel-7@1(peon).data_health(6) update_stats avail 89% total 30708 MB, used 3311 MB, avail 27397 MB

Expected results:

Debug messages don't get sent to wall.

Additional info:

Upstream has already backported to hammer, should be a simple backport.
Comment 2 Ken Dreyer (Red Hat) 2016-02-25 16:25:46 EST
This looks like bug 1276186 - Brad, can you confirm?
Comment 3 Brad Hubbard 2016-02-25 17:35:13 EST
Yes, duplicate of bz1276186

*** This bug has been marked as a duplicate of bug 1276186 ***

Note You need to log in before you can comment on or make changes to this bug.