Bug 1312158 - livemedia-creator fails when a squashfs is bigger than 4GiB
livemedia-creator fails when a squashfs is bigger than 4GiB
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
: 1319067 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-25 17:25 EST by Dennis Gilmore
Modified: 2016-03-18 15:09 EDT (History)
3 users (show)

See Also:
Fixed In Version: lorax-25.3-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-18 15:06:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Gilmore 2016-02-25 17:25:26 EST
Description of problem:
2016-02-25 22:19:34,713 DEBUG pylorax.ltmpl: template line 25: runcmd mkisofs -o /var/tmp/lmc-work-kt98yzin/images/boot.iso -b isolinux/isolinux.bin -c isolinux/boot.cat -boot-load-size 4 -boot-info-table -no-emul-boot -R -J -V Fedora-Live-Game-Rawhide-2016022 -T -graft-points isolinux=/var/tmp/lmc-work-kt98yzin/isolinux images/pxeboot=/var/tmp/lmc-work-kt98yzin/images/pxeboot LiveOS=/var/tmp/lmc-work-kt98yzin/LiveOS
2016-02-25 22:19:34,713 DEBUG pylorax.ltmpl: running command: ('mkisofs', '-o', '/var/tmp/lmc-work-kt98yzin/images/boot.iso', '-b', 'isolinux/isolinux.bin', '-c', 'isolinux/boot.cat', '-boot-load-size', '4', '-boot-info-table', '-no-emul-boot', '-R', '-J', '-V', 'Fedora-Live-Game-Rawhide-2016022', '-T', '-graft-points', 'isolinux=/var/tmp/lmc-work-kt98yzin/isolinux', 'images/pxeboot=/var/tmp/lmc-work-kt98yzin/images/pxeboot', 'LiveOS=/var/tmp/lmc-work-kt98yzin/LiveOS')
2016-02-25 22:19:34,795 DEBUG pylorax.ltmpl: command output:
File /var/tmp/lmc-work-kt98yzin/LiveOS/squashfs.img is larger than 4GiB-1.
-allow-limited-size was not specified. There is no way do represent this file size. Aborting.

We need to be able to build livecds with bigger payloads.
Comment 1 Brian Lane 2016-02-25 19:03:58 EST
I'm not sure if there is anything we can do here other than not install so much stuff.
Comment 2 Brian Lane 2016-03-16 19:56:17 EDT
Ends up livecd-creator switches to UDF when the squashfs.img file is too big.

https://github.com/rhinstaller/lorax/pull/98
Comment 3 Brian Lane 2016-03-18 15:09:08 EDT
*** Bug 1319067 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.