Bug 1312178 - Kernel 4.4.2 does not boot on DELL PRECISION T7610
Kernel 4.4.2 does not boot on DELL PRECISION T7610
Status: CLOSED DUPLICATE of bug 1313025
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-25 19:51 EST by Sammy
Modified: 2016-02-29 17:28 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-29 17:07:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen shot from journalctl (137.99 KB, image/jpeg)
2016-02-29 09:51 EST, Sammy
no flags Details

  None (edit)
Description Sammy 2016-02-25 19:51:10 EST
Kernel 4.4.2 fails to mount root and swap partitions on DELL PRECISION T7610.
Older and newer DELL PRECISIONS (T7910) are working fine with identical setup.

Grub is able to load the initrd image with a brief disk access. Subsequently
no disk activity occurs until (3-4min) a dracut message appears satating that
it cannot find:

fedora_dhcp-129-59-117-106/root
fedora_dhcp-129-59-117-106/swap

Going back the 4.3.5 works fine. The content of grub.cfg for the two kernels
is identical.

Tested DELL BIOS's A08 and A10 for T7610.
Comment 1 Laura Abbott 2016-02-25 20:08:52 EST
Can you share full journalctl output for both working and non-working cases?
Comment 2 Sammy 2016-02-25 20:15:04 EST
How do I do this on the non-working case? It does not boot! If there is a way I
will do this tomorrow morning when I am at work.
Comment 3 Laura Abbott 2016-02-25 20:55:02 EST
If you're seeing a dracut message that means it's booting enough. Can you set it up to drop into a dracut shell? https://fedoraproject.org/wiki/How_to_debug_Dracut_problems#Using_the_dracut_shell
Comment 4 Sammy 2016-02-26 08:56:35 EST
Sorry but need more direction....I am at the dracut shell prompt. I insert a usb
stick in. The light of the stick stays on. Where is the device name and how do
I mount it?
Comment 5 Sammy 2016-02-26 11:44:22 EST
I boot with the usb stick in and the dracut log shows that it was recognized but
I can't find how to mount it. blkid gives nothing.
Comment 6 Sammy 2016-02-29 09:51 EST
Created attachment 1131571 [details]
Screen shot from journalctl
Comment 7 Sammy 2016-02-29 09:52:30 EST
This is from 4.4.3-300 installed this morning. The problem persists.
Comment 8 Laura Abbott 2016-02-29 13:57:26 EST
I'm wondering if this is the same issue as https://bugzilla.redhat.com/show_bug.cgi?id=1313025 . Can you run the following commands and see if it gives you any output:

# lsinitrd -k 4.3.5-300.fc23.x86_64 | grep mpt3sas
# lsinitrd -k 4.3.5-300.fc23.x86_64 | grep mpt2sas

This is checking the initrd of the last kernel version that worked for you (4.3.5 which was mentioned in the other thread) to see if it contains a particular kernel module. If I didn't get the kernel version correct, please change the version to the actual last version that worked for you.
Comment 9 Sammy 2016-02-29 16:22:37 EST
On the 4.3.5-300:

# lsinitrd -k 4.3.5-300.fc23.x86_64 | grep mpt3sas
# lsinitrd -k 4.3.5-300.fc23.x86_64 | grep mpt2sas
drwxr-xr-x   2 root     root            0 Feb  1 08:43 usr/lib/modules/4.3.5-300.fc23.x86_64/kernel/drivers/scsi/mpt2sas
-rw-r--r--   1 root     root        81284 Jan 31 22:08 usr/lib/modules/4.3.5-300.fc23.x86_64/kernel/drivers/scsi/mpt2sas/mpt2sas.ko.xz

I do believe this system uses one of these.
Comment 10 Laura Abbott 2016-02-29 17:07:43 EST
Thanks for checking. I'm almost certain this is a duplicate of that bug based on the output. The issue is in dracut and not the kernel. For a workaround you can do

# dracut --force --add-drivers mpt3sas --kver=4.4.2-300.fc23.x86_64

and then run the lsinitrd command to confirm that mpt3sas driver is being included in your initrd. You will need to run this dracut command to add the driver every time you change the kernel or put add_drivers+="mpt3sas" in your /etc/dracut.conf

*** This bug has been marked as a duplicate of bug 1313025 ***
Comment 11 Sammy 2016-02-29 17:28:29 EST
I will do this as soon as a job ends. But it makes sense since one of the
working systems have the Fusion-MPT SAS-3 but the non working system has
Fusion-MPT SAS-2. If the name changed to SAS3 then the working system pick to
correct one but since there is no sas2 it fails.

Note You need to log in before you can comment on or make changes to this bug.