Bug 131218 - [RHEL4] Characters get truncated in new pango
Summary: [RHEL4] Characters get truncated in new pango
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: pango (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Owen Taylor
QA Contact:
URL:
Whiteboard:
Keywords: i18n
Depends On:
Blocks: 131589
TreeView+ depends on / blocked
 
Reported: 2004-08-30 04:32 UTC by Lawrence Lim
Modified: 2014-03-26 00:50 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-18 21:51:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xchat with pango 1.4.0-2 (82.45 KB, image/png)
2004-08-30 04:33 UTC, Lawrence Lim
no flags Details
xchat with pango 1.5 (66.82 KB, image/png)
2004-08-30 04:35 UTC, Lawrence Lim
no flags Details
xchat with pango-1.6.0-4 (230.36 KB, image/png)
2004-10-19 02:31 UTC, Lawrence Lim
no flags Details

Description Lawrence Lim 2004-08-30 04:32:20 UTC
Description of problem:
With pango 1.5 in the ja_JP locale, most of the charcters at the end
of each line are truncated. Also, changing the style on the same line,
like in between regular style and bold, there is no spacing between
those glyphs, which is not very ideal.

Downgraded pango on my machine from 1.5 to 1.4 and the difference
between the xchat screenshot varies quite a lot. Please refer to the
screenshots.

Version-Release number of selected component (if applicable):
pango 1.4

How reproducible:
Always

Steps to Reproduce:
1.start xchat in the CJK locale
2.
3.
  
Actual results:
Characters get truncated.

Expected results:
Similar to pango 1.4 screenshot

Additional info:

Comment 1 Lawrence Lim 2004-08-30 04:33:28 UTC
Created attachment 103227 [details]
xchat with pango 1.4.0-2

Comment 2 Lawrence Lim 2004-08-30 04:35:52 UTC
Created attachment 103228 [details]
xchat with pango 1.5

Comment 3 Owen Taylor 2004-09-09 21:26:46 UTC
This looks rather like a xchat bug, but I'll investigate.


Comment 4 Owen Taylor 2004-09-14 14:55:19 UTC
Actually the vertical and horizontal spacing problems are 
different.

The vertical spacing problem is a Pango bug:

 http://bugzilla.gnome.org/show_bug.cgi?id=149438

The horizontal spacing problem is an xchat bug (bug 132527)


Comment 5 Alexander Larsson 2004-10-12 12:16:22 UTC
What is the status on the pango problem?


Comment 6 Warren Togami 2004-10-15 04:42:14 UTC
Still problematic in today's rawhide, confirmed in LANG=zh_CN.UTF8

Comment 7 Owen Taylor 2004-10-18 21:51:11 UTC
Should be fixed with pango-1.6.0-4

Comment 8 Lawrence Lim 2004-10-19 02:31:50 UTC
Created attachment 105414 [details]
xchat with pango-1.6.0-4

Comment 9 Lawrence Lim 2004-10-19 02:34:08 UTC
Owen,
Noticed some of the lines are still not displayed properly. Could you
please verify if this vertical spacing problem (Pango) bug or
horizontal spacing problem (xchat) bug?


Thanks.

Comment 10 Lawrence Lim 2004-10-19 02:35:05 UTC
I was testing with xchat-2.4.0-3, btw. :)

Comment 11 Owen Taylor 2004-10-19 15:20:55 UTC
Is there any reason you would think that was a vertical spacing
problem? The trunctation seems to be all horizontal.


Comment 12 Lawrence Lim 2004-10-20 02:11:16 UTC
OK, I will update bug 132527 then.

Thanks.


Note You need to log in before you can comment on or make changes to this bug.