Bug 1312197 - fedora-release-24.0-10 update scriptlet failure
fedora-release-24.0-10 update scriptlet failure
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: fedora-release (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stephen Gallagher
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-25 23:56 EST by Parag Nemade
Modified: 2016-03-29 08:07 EDT (History)
9 users (show)

See Also:
Fixed In Version: fedora-release-24-0.16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-29 08:07:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Parag Nemade 2016-02-25 23:56:55 EST
Description of problem:

I wanted my rawhide vm to stay on Fedora 24 so i downloaded fedora-release and fedora-release-workstation rpms and used dnf to update them as

[parag@localhost ~]$ sudo dnf update ./fedora-release-*
Last metadata expiration check performed 0:28:20 ago on Fri Feb 26 09:53:13 2016.
Dependencies resolved.
======================================================================================
 Package                          Arch         Version       Repository          Size
======================================================================================
Upgrading:
 fedora-release                   noarch       24-0.10       @commandline        17 k
 fedora-release-workstation       noarch       24-0.10       @commandline        12 k

Transaction Summary
======================================================================================
Upgrade  2 Packages

Total size: 29 k
Is this ok [y/N]: y
Downloading Packages:
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Upgrading   : fedora-release-24-0.10.noarch                                     1/4 
  Upgrading   : fedora-release-workstation-24-0.10.noarch                         2/4 
Usage: convert-to-edition [options] -e cloud|non-edition|server|workstation
    Options:
        -e: The edition to install (cloud, non-edition, server or workstation)
        -i: Skip installing additional files and just update symlinks
        -p: Also enable newly-added systemd presets
warning: %post(fedora-release-workstation-24-0.10.noarch) scriptlet failed, exit status 1
Non-fatal POSTIN scriptlet failure in rpm package fedora-release-workstation
Non-fatal POSTIN scriptlet failure in rpm package fedora-release-workstation
  Cleanup     : fedora-release-workstation-24-0.6.noarch                          3/4 
  Cleanup     : fedora-release-24-0.6.noarch                                      4/4 
  Verifying   : fedora-release-24-0.10.noarch                                     1/4 
  Verifying   : fedora-release-workstation-24-0.10.noarch                         2/4 
  Verifying   : fedora-release-24-0.6.noarch                                      3/4 
  Verifying   : fedora-release-workstation-24-0.6.noarch                          4/4 

Upgraded:
  fedora-release.noarch 24-0.10       fedora-release-workstation.noarch 24-0.10      

Complete!

Version-Release number of selected component (if applicable):
fedora-release-24-0.10

How reproducible:
should be always

Steps to Reproduce:
1.On rawhide machine state before pulling F25/rawhide update
2.download fedora-release-24-0.10 package and update it.
3.

Actual results:
scriptlet failed

Expected results:
no  scriptlet failure

Additional info:
Comment 1 Parag Nemade 2016-02-26 01:22:04 EST
Note I already update fedora-repos manually using dnf with no issues.
Comment 2 Hans de Goede 2016-02-26 04:40:56 EST
Hi,

I just saw this too, the fix is to change:

        /usr/sbin/convert-to-edition -ip workstation

To:

        /usr/sbin/convert-to-edition -ie workstation

In the "else" case in the %postinstall doing so matches the comment above it, it looks like the '-e' got dropped in the else instead of the '-p' (which is clearly the intent looking at the comment) and not having
a -e makes convert-to-edition unhappy.

Regards,

Hans
Comment 3 Hans de Goede 2016-02-26 04:46:21 EST
p.s.

Also the 24.0-10 build still seems to have rawhide enabled and fedora and fedora-updates disabled ?
Comment 4 Hans de Goede 2016-02-26 05:14:50 EST
(In reply to Hans de Goede from comment #3)
> p.s.
> 
> Also the 24.0-10 build still seems to have rawhide enabled and fedora and
> fedora-updates disabled ?

Never mind, that is in fedora-repos of course, my bad.
Comment 5 Stephen Gallagher 2016-02-26 08:20:53 EST
Crud... I thought I tested all of the upgrade paths... stupid typos. I'll get a fix out ASAP.
Comment 6 Stephen Gallagher 2016-02-26 08:37:03 EST
I've submitted a PR with the fix to upstream.

https://pagure.io/fedora-release/pull-request/25


Dennis, please apply this and build it immediately. I made a copy-paste error and then apparently only spot-checked Server and non-product, thus leaving this mistake behind
Comment 7 Stephen Gallagher 2016-02-26 09:09:09 EST
I verified with Parag on IRC that the effect of this bug is to leave the os-release and other files exactly where they would have been prior to the upgrade, so it's not going to cause a broken system, fortunately.
Comment 8 Peter Robinson 2016-03-01 03:39:30 EST
*** Bug 1313147 has been marked as a duplicate of this bug. ***
Comment 9 Mike McCune 2016-03-28 19:33:48 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Note You need to log in before you can comment on or make changes to this bug.