Bug 1312207 - RFE: Add self-heal monitoring nagios plugin
RFE: Add self-heal monitoring nagios plugin
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: nagios-server-addons (Show other bugs)
3.1
Unspecified Unspecified
medium Severity medium
: ---
: RHGS 3.1.3
Assigned To: Sahina Bose
Sweta Anandpara
: FutureFeature, ZStream
Depends On: 1267586
Blocks: Gluster-HC-1 1311386 1320438
  Show dependency treegraph
 
Reported: 2016-02-26 00:58 EST by Sahina Bose
Modified: 2016-06-23 01:27 EDT (History)
6 users (show)

See Also:
Fixed In Version: nagios-server-addons-0.2.4-1
Doc Type: Enhancement
Doc Text:
A Nagios plugin has been added to monitor if a replicate volume has entries that are not in sync with other bricks of the replica set. Now, administrators can ensure that they do not perform maintenance actions when there are pending heals, and can also monitor the heal progress by viewing the trending information on entries to be healed.
Story Points: ---
Clone Of: 1267586
Environment:
Last Closed: 2016-06-23 01:27:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sahina Bose 2016-02-26 00:58:28 EST
+++ This bug was initially created as a clone of Bug #1267586 +++

Description of problem:

Administrators need a way to be notified when self-heal is in progress, or when there are unsynced entries present in a replicated volume. 

Administrators need to be alerted if:
1. self heal is ongoing for a period of time (configurable)
2. if unsynced entries are increasing or constant over a period of time

Version-Release number of selected component (if applicable):


How reproducible:
NA


Additional info:

--- Additional comment from Sahina Bose on 2015-09-30 09:57:30 EDT ---

http://review.gluster.org/12260, http://review.gluster.org/12261, http://review.gluster.org/12262 - patches posted
Comment 3 Mike McCune 2016-03-28 19:32:32 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 4 Sweta Anandpara 2016-04-25 07:06:13 EDT
Tested and verified this on the build nagios-server-addons 0.2.4-1 and gluster-server 3.7.9-2

The sanity check on the new service 'volume Heal info' and the corresponding 'Volume Split-brain status' is complete. New BZs are raised for issues faced while executing the test cases in and around this area. 

Moving this RFE to fixed in 3.1.3
Comment 6 Sahina Bose 2016-06-08 03:38:58 EDT
acked
Comment 8 errata-xmlrpc 2016-06-23 01:27:39 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1242

Note You need to log in before you can comment on or make changes to this bug.