Bug 1312218 - Pod status are not shown on Pod Logs tab
Pod status are not shown on Pod Logs tab
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Management Console (Show other bugs)
3.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: bpeterse
yapei
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-26 01:42 EST by yapei
Modified: 2016-05-12 13:15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-12 13:15:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description yapei 2016-02-26 01:42:37 EST
Description of problem:
When viewing pod logs on "Logs" tab, pod status are not displayed. both Builds and Deployment have status on their Logs page

Version-Release number of selected component (if applicable):
devenv-rhel7_3540

How reproducible:
Always

Steps to Reproduce:
1.Create application
2.Check pod log

Actual results:
2. Pod status are not shown on "Logs" tab

Expected results:
2. Pod status should be indicated on "Logs" tab

Additional info:
Comment 1 Samuel Padgett 2016-02-26 09:11:16 EST
This was intentionally removed because it was misleading. See

https://github.com/openshift/origin/issues/7414

We should be able to add it back as container state, however.
Comment 2 bpeterse 2016-02-29 14:05:50 EST
PR is in the works here: https://github.com/openshift/origin/pull/7669

Will update this ticket soon.
Comment 3 openshift-github-bot 2016-03-05 04:51:44 EST
Commit pushed to master at https://github.com/openshift/origin

https://github.com/openshift/origin/commit/6f51b9ce55896f756a2633e1b8d3ce13b962e4e7
fixes bug 1312218 (bugzilla), fixes #7646 (github)

- also fix ng-if=end to ng-if=timeEnd in logViewer template
- check containerStatus.state, fallback to containerStatus.lastState
- pull status, start & end time from log viewer to allow more granular control on each page
- update pod page to use container status,start & end time
- update build, deployment pages log details
- update pod log message to indicate current log or previous log (using state / lastState)
- update log header message area to improve appearance/responsiveness
- add capitalize filter, move some filters to strings.js file
- add few minor typographic css classes to typography.lesst push
Comment 4 yapei 2016-03-06 21:07:58 EST
checked against devenv-rhel7_3629, now in Pod Logs tab, container status are added, so move this bug to VERIFIED

Will continue to test other changed function
Comment 5 yapei 2016-03-06 22:29:27 EST
Checked Pod Logs with container status/last state, started time and end time 
Build logs with started time and end time
Deployment logs with started time and end time

Works well

Note You need to log in before you can comment on or make changes to this bug.