Bug 1312228 - Failed to get mapping info if one of the esx host is unreachable after reboot vcenter
Failed to get mapping info if one of the esx host is unreachable after reboo...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-who (Show other bugs)
6.8
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Radek Novacek
Eko
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-26 02:48 EST by Liushihui
Modified: 2016-11-30 19:35 EST (History)
5 users (show)

See Also:
Fixed In Version: virt-who-0.16-7.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 19:57:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Liushihui 2016-02-26 02:48:13 EST
Description of problem:
After reboot vcenter, if anyone of esx host in disconnect status, virt-who will failed to get all host/guest mapping info as failed to get hostname.

Version-Release number of selected component (if applicable):
virt-who-0.16-5.el6.noarch
subscription-manager-1.16.8-3.el6.x86_64
python-rhsm-1.16.6-1.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Register system to satellite6.1, configure virt-who run at esx mode, and there are two esx host(both are reachable) in vcenter.
[root@hp-z220-07 run]# cat /etc/sysconfig/virt-who  | grep -v ^# | grep -v ^$
VIRTWHO_DEBUG=1
[test-esx1]
type=esx
server=10.66.78.89
username=Administrator@vsphere.local
password=Welcome1!
owner=ACME_Corporation
env=Library
2. Restart virt-who service, virt-who can send host/guest mapping info to server.
3. Disconnect one esx host in vcenter, then check virt-who's log, virt-who still can send host/guest mapping info to server.
4. Reboot windows system which installed vcenter, then check virt-who's log
2016-02-26 15:36:44,614 [virtwho.test-esx1 DEBUG] Esx-1(26238):MainThread @esx.py:_prepare:55 - Log into ESX
2016-02-26 15:36:44,959 [virtwho.test-esx1 DEBUG] Esx-1(26238):MainThread @esx.py:_prepare:58 - Creating ESX event filter
2016-02-26 15:36:45,086 [virtwho.test-esx1 ERROR] Esx-1(26238):MainThread @virt.py:run:371 - Virt backend 'test-esx1' fails with exception:
Traceback (most recent call last):
  File "/usr/share/virt-who/virt/virt.py", line 366, in run
    self._run()
  File "/usr/share/virt-who/virt/esx/esx.py", line 141, in _run
    assoc = self.getHostGuestMapping()
  File "/usr/share/virt-who/virt/esx/esx.py", line 214, in getHostGuestMapping
    name = '%(config.network.dnsConfig.hostName)s.%(config.network.dnsConfig.domainName)s' % host
KeyError: 'config.network.dnsConfig.hostName'
2016-02-26 15:36:45,087 [virtwho.test-esx1 INFO] Esx-1(26238):MainThread @virt.py:run:384 - Waiting 60 seconds before retrying backend 'test-esx1'

Actual results:
Failed to get host/guest mapping info if anyone of esx host is in disconnect status after reboot vcenter

Expected results:
Virt-who should send the normal host/guest mapping info satellite, it also can state the unreachable host in the log.

Additional info:
Comment 1 Radek Novacek 2016-03-10 13:26:45 EST
Fixed in virt-who-0.16-7.el6.
Comment 3 Liushihui 2016-03-23 05:15:21 EDT
Verified it on virt-who-0.16-7.el6 since virt-who can send the disconnected esx host's mapping info to server after reboot vcenter. Therefore, verify it.
Comment 5 errata-xmlrpc 2016-05-10 19:57:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0859.html

Note You need to log in before you can comment on or make changes to this bug.