Bug 131226 - gnome-terminal crashes with im-xim module
Summary: gnome-terminal crashes with im-xim module
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: vte   
(Show other bugs)
Version: 2
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact:
URL:
Whiteboard:
Keywords: i18n
Depends On:
Blocks: IIIMF 131589
TreeView+ depends on / blocked
 
Reported: 2004-08-30 06:37 UTC by Nakai
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-18 02:15:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nakai 2004-08-30 06:37:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.6) Gecko/20040510

Description of problem:
gnome-terminal crashes easily when im-xim immodule is selected.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Japanese environment
2. GTK_IM_MODULE=xim gnome-terminal
3. Input some Japanese text and leave it as preedit string.
4. Click up-right of the window to close the gnome-terminal
5. Crash

Actual Results:  Crash, crash!

Expected Results:  Not crash

Additional info:

It doesn't crash with im-iiim because its current implementation
don't have effective code in reset function. But it might have
in the future. ( The comment is saying /* TODO */ )

I confirm this bug only with Japanese environment, but it is
supposed to happen on Korean and Chinese XIM environment.

Patch to fix:
http://bugzilla.gnome.org/show_bug.cgi?id=134800

Comment 1 Nakai 2004-08-30 06:39:15 UTC
The target component is vte. Reassign.

Comment 2 Nakai 2004-10-14 09:35:06 UTC
Not fixed in FC3T2.

Comment 3 Matthias Clasen 2004-10-15 19:15:28 UTC
Fixed in vte-0.11.11-6

Comment 4 Lawrence Lim 2004-10-18 07:56:51 UTC
Confirmed fixed.

Tested with XIM input method: kinput2-canna, nabi, xcin and minichinput.
Tested with IIIMF input method: Canna, hangul, xcin and chinput.


Thanks.


Note You need to log in before you can comment on or make changes to this bug.