Bug 1312271 - Firstboot : Unhandled Exception Message when you click on forward button without entering the credentials
Firstboot : Unhandled Exception Message when you click on forward button with...
Status: CLOSED DUPLICATE of bug 1311935
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.8
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
John Sefler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-26 04:50 EST by Shwetha Kallesh
Modified: 2016-02-29 15:21 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-29 15:21:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Unhandled Exception Message (233.84 KB, image/png)
2016-02-26 04:51 EST, Shwetha Kallesh
no flags Details
Activation key window exception (241.17 KB, image/png)
2016-02-29 09:20 EST, Shwetha Kallesh
no flags Details

  None (edit)
Description Shwetha Kallesh 2016-02-26 04:50:37 EST
Description of problem:
Unhandled Exception Message is thrown when you click on forward button without entering the credentials , instead a message saying you must enter a login should be thrown to the user

Version-Release number of selected component (if applicable):

[root@dhcp35-29 ~]# subscription-manager version
server type: This system is currently not registered.
subscription management server: 0.9.51.15-1
subscription management rules: 5.15.1
subscription-manager: 1.16.8-3.el6
python-rhsm: 1.16.6-1.el6


How reproducible:

Steps to Reproduce:

a) Launch firstboot
b) Accept the license and choose to register to RHSM
c) Enter the server details
d) "DONOT" enter any username or password
e) Click on Forward button

Actual results:
Unhandled Exception Message is thrown

Expected results:
a message saying you must enter a login should be thrown to the user

Additional info:
Comment 1 Shwetha Kallesh 2016-02-26 04:51 EST
Created attachment 1130806 [details]
Unhandled Exception Message
Comment 3 Shwetha Kallesh 2016-02-29 09:20 EST
Created attachment 1131567 [details]
Activation key window exception

Observed that when you click on forward without entering activation key credentials unhandled exception is thrown
Comment 4 Barnaby Court 2016-02-29 15:21:48 EST

*** This bug has been marked as a duplicate of bug 1311935 ***

Note You need to log in before you can comment on or make changes to this bug.