Bug 1312309 - [GSS] Log statements in process-controller logs when wrong JVM settings are configured
[GSS] Log statements in process-controller logs when wrong JVM settings are c...
Status: CLOSED NOTABUG
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: jbossas (Show other bugs)
6.4.1
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Petr Jurak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-26 06:34 EST by Saisha Naik
Modified: 2016-10-20 03:30 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-20 03:30:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saisha Naik 2016-02-26 06:34:26 EST
Description of problem:

When there is any wrong JVM argument present in the server-group, JBoss throws the below message on the console. There is no server.log created for any of the servers inside that server-group.
--------------
[Server:server-two] Unrecognized VM option 'foo'
[Server:server-two] Could not create the Java virtual machine.
15:28:58,923 INFO  [org.jboss.as.process.Server:server-two.status] (reaper for Server:server-two) JBAS012010: Process 'Server:server-two' finished with an exit status of 1
----------------

When JBoss is started using nohup(nohup ./domain.sh), there is no console logging. So it is difficult to find the actual cause of the issue.

In the process-controller log, the below message is logged:
------------------
I can see the following in process-controller.log (also see attached process-controller.log):
2016-02-18 14:20:46,232 [reaper for Server:server-1] INFO  org.jboss.as.process.Server:server-1.status - JBAS012010: Process 'Server:server-1' finished with an exit status of 1
-------------------

However, there is no message in the process-controller logs that indicates the error is due to a misconfigured JVM option as stated in the console logs.

Version-Release number of selected component (if applicable):

How Reproducible : Always

Steps to Reproduce:

1. Start JBoss using nohup ./domain.sh.

2. Add the following JVM options under server-group :
-------------------
<jvm-options>
      <option value="-server"/>
      <option value="-verbose:gc"/>
      <option value="-XX:+DisableExplicitGC"/>
      <option value="-XX:+PrintGCDateStamps"/>
      <option value="-XX:+PrintGCDetails"/>
      <option value="-XX:+UseConcMarkSweepGC"/>
      <option value="-XX:foo"/>
</jvm-options>
-------------------

Actual results:

Actual result is :
------------------
18:31:29,616 INFO  [org.jboss.as.process.Server:server-one.status] (ProcessController-threads - 3) JBAS012017: Starting process 'Server:server-one'
18:31:30,050 INFO  [org.jboss.as.process.Server:server-one.status] (reaper for Server:server-one) JBAS012010: Process 'Server:server-one' finished with an exit status of 1
------------------

No reason is logged for failure.

Expected results:

Expected Result should be the following message in process-controller logs:
------------------
[Server:server-two] Unrecognized VM option 'foo'
[Server:server-two] Could not create the Java virtual machine.
15:28:58,923 INFO  [org.jboss.as.process.Server:server-two.status] (reaper for Server:server-two) JBAS012010: Process 'Server:server-two' finished with an exit status of 1
------------------
Comment 1 Chao Wang 2016-03-01 00:06:35 EST
$ nohup ./domain.sh
nohup: ignoring input and appending output to ‘nohup.out’


It looks to me command above redirected log information to file nohup.out where you can find out the specific failure reason.

Note You need to log in before you can comment on or make changes to this bug.