Bug 131232 - iiimf-le-xcin cannot handle lib64
iiimf-le-xcin cannot handle lib64
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: iiimf-le-xcin (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Leon Ho
: i18n
Depends On:
Blocks: FC3Target IIIMF
  Show dependency treegraph
 
Reported: 2004-08-30 05:40 EDT by Warren Togami
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-30 21:19:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2004-08-30 05:40:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040808 Firefox/0.9.3

Description of problem:
iiimf-le-xcin-0.1.7-3 (in CVS) fails to build after /usr/lib was
replaced with proper %{_libdir} macros because the source does not
know how to handle lib64.  With the earlier /usr/lib hard coded, I
suspect it was incorrectly putting 64bit binaries into the 32bit
/usr/lib, which is wrong.

Version-Release number of selected component (if applicable):
iiimf-le-xcin-0.1.7-3 (CVS)
Comment 1 Leon Ho 2004-08-30 21:19:47 EDT
Main problem was the the $IMDIR in im-sdk macro are hardcoded in
/usr/lib/im. Fixed by using the searah and replace script in im-sdk
spec. Also generalized one automake file as well. Fixed on 0.1.7-4.
Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.