Bug 131233 - Tutorial About Installing a Simple Gateway Server
Tutorial About Installing a Simple Gateway Server
Status: CLOSED DEFERRED
Product: Fedora Documentation
Classification: Fedora
Component: docs-requests (Show other bugs)
devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Wade
Paul W. Frields
http://www.soft.inima.al/docs/
: FutureFeature
Depends On:
Blocks: fedora-docs-writing
  Show dependency treegraph
 
Reported: 2004-08-30 06:33 EDT by Dashamir Hoxha
Modified: 2009-08-12 12:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-12 12:04:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The files of the tutorial gateway server (187.61 KB, application/octet-stream)
2004-09-04 07:15 EDT, Dashamir Hoxha
no flags Details
The files of the tutorial gateway server (93.05 KB, application/gzip)
2004-09-29 11:44 EDT, Dashamir Hoxha
no flags Details
The files of the tutorial gateway server (302.73 KB, text/plain)
2004-10-14 11:37 EDT, Dashamir Hoxha
no flags Details

  None (edit)
Description Dashamir Hoxha 2004-08-30 06:33:13 EDT
Description of problem:
This tutorial describes the installation and configuration of a small
linux server that is used as gateway to the Internet and as a web
server for a small company or institution. 

The intended audience:
The not so advanced linux admins (newby linux admins).
Comment 1 Tammy Fox 2004-08-30 09:42:11 EDT
Great! Thanks for writing this tutorial. I'll read it over in the next
few days and then assign you an editor to help you get it ready to add
to the Fedora Docs.
Comment 2 Dashamir Hoxha 2004-08-31 03:38:28 EDT
I would like to have a look at the Documentation Guide and then make
the  modifications myself. However, having an editor for help just in
case that I have problems, is not a bad idea.
Comment 3 Dashamir Hoxha 2004-09-04 07:15:09 EDT
Created attachment 103462 [details]
The files of the tutorial gateway server

I am sorry for the previous comment, I thought that an editor is for fixing the

problems in the document (both language and DocBook style). Now I understand
that
the role of the editor is just to tell how to fix them and to verify that the
document complies with the rules and guides.

I have attached a first version of the tutorial. I know that it is far from 
finished, however I would like to have the help of an editor to find and fix
the bugs. I have described the things that I know that are to be fixed in the
file 'ToDo.txt'.

First, I think that I should solve with the editor the matter of the DocBook
tags and style that are used, until the document becomes acceptable.

Next, I am going to pay more attention to the content, adding or removing any
section, verifying that the commands and links are OK, etc. (with any
suggestions from the editor, as well).

Finally, I am going to focus on English mistakes (spellchecking, grammer, etc.)


The attachment includes also a CVS directory with anonymous access to my
server,
so for the next releases there may be no need for patches or attachments (if
'cvs update' works).
Comment 4 Dashamir Hoxha 2004-09-29 11:44:31 EDT
Created attachment 104511 [details]
The files of the tutorial gateway server

Is there anybody interested in reviewing the tutorial, in order to point out
any mistakes or make any suggestions?
Comment 5 Tammy Fox 2004-09-29 14:27:44 EDT
Sure. I used to maintain a Linux gateway server at my house until I
recently bought a small Netgear box.

I see several DocBook XML files in the tarball. Which one is the
master file I should be looking at? It looks like your convert.sh
script is converting the files with dashes to files with underscores
but I don't understand why that is needed to go from XML to XML.
Comment 6 Dashamir Hoxha 2004-09-30 02:39:33 EDT
The master file is the one that complies with the filename conventions,
that is: gateway-server-en.xml . 'convert.sh' converts from files with
underscores to files with dashes. It is needed because the original
file (the one with underscores) does not comply with the conventions
of FDP, e.g. articleinfo has a different format, it has a GNU FDL
section at the end, etc. The files with 'al' are intended to be the
albanian translation, however this is not done yet.

If you want to review it yourself this is fine. However I did not mean
to assign it to you. It was automatically assigned to you by bugzilla,
you know yourself why.
Comment 7 Tammy Fox 2004-09-30 10:36:08 EDT
All bugs have to have a default owner, so that is why it was assigned
to me initially. I would assign it to a different editor, but they are
all busy working on other Fedora docs at the moment, so I thought I
would take this one. Thanks for explaining the difference between the
files. I'll attach a diff to this bug report when I finish the edits.
Comment 8 Tammy Fox 2004-09-30 10:49:50 EDT
Sorry. One more question so I don't edit the wrong file. Do you need
to keep the one with underscores around? If so, I'll edit it since
your Makefile runs convert.sh everytime to produce the output. If not,
I'll edit the one with dashes and change the Makefile to use it instead.
Comment 9 Dashamir Hoxha 2004-09-30 11:02:30 EDT
If possible, please edit 'gateway_server_en.xml'.

Also, please consider making your editings instead at: 
http://www.soft.inima.al/docs/edit.php 
(username: tfox, passwd: Tammy_Fox)

I can also give you write access to my cvs server, if you prefer,
so that you don't need to send patches (the coppy that you have
has only readonly anonymous access).
Comment 10 Tammy Fox 2004-09-30 11:12:55 EDT
Ah! What an interesting way to edit DocBook. If I make the change via
the website does it automatically update the files in CVS as well?
Comment 11 Dashamir Hoxha 2004-09-30 11:16:58 EDT
No so automatically yet, but by running one or two scripts manually.
Comment 12 Tammy Fox 2004-09-30 12:21:54 EDT
OK. Then if you can give me write access to your CVS server, I can
make my edits there and you can view the diffs. Please send me the
info in email so the whole world doesn't have write access. ;-)
Comment 13 Dashamir Hoxha 2004-10-14 11:37:37 EDT
Created attachment 105203 [details]
The files of the tutorial gateway server
Comment 14 Karsten Wade 2005-08-18 15:31:08 EDT
What is the status on this document?

Are you interested in getting it into Fedora Documentation CVS, now that it exists?

Tammy, is it worth publishing a beta?  We've done a few at
http://fedora.redhat.com/docs/beta/.

What would it take to get this updated for FC4?  FC3 is still viable for four or
five months.
Comment 15 Karsten Wade 2005-12-27 14:18:31 EST
Added to the list of docs ideas as an orphaned document.  If the original author
is not interested in publishing it here, perhaps someone else is.

http://fedoraproject.org/wiki/DocsProject/DocIdeas

For the record, I apologize for the difficulty anyone faced in the past getting
documents published through Fedora.  Hopefully we are better at it than we used
to be. :)
Comment 16 eric@christensenplace.us 2009-08-05 14:26:55 EDT
What is the status of this?  Can this ticket be closed?
Comment 17 eric@christensenplace.us 2009-08-12 12:04:00 EDT
If this bug is still needed please reopen and provide additional information.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.