Bug 1312334 - python-flickrapi: Provide a Python 3 subpackage
python-flickrapi: Provide a Python 3 subpackage
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-flickrapi (Show other bugs)
25
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Maxim Burgerhout
Fedora Extras Quality Assurance
:
Depends On:
Blocks: PYTHON3 PY3PATCH-AVAILABLE
  Show dependency treegraph
 
Reported: 2016-02-26 08:01 EST by Tomas Orsava
Modified: 2017-04-06 04:00 EDT (History)
4 users (show)

See Also:
Fixed In Version: python-flickrapi-2.2.1-1.fc26
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-04-05 18:00:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
add Python 3 & update version (3.76 KB, patch)
2016-08-23 09:20 EDT, Dominika Krejčí
no flags Details | Diff
Add Python 3 support and update to 2.2.1 (5.11 KB, application/mbox)
2017-03-28 11:09 EDT, Iryna Shcherbina
no flags Details

  None (edit)
Description Tomas Orsava 2016-02-26 08:01:01 EST
Upstream, this software supports Python 3. Please provide a Python 3
package for Fedora.


According to the Python packaging guidelines [0], software must be
packaged for Python 3 if upstream supports it.
The guidelines give detailed information on how to do this, and even
provide an example spec file [1].

The current best practice is to provide subpackages for the two Python
versions (called "Common SRPM" in the guidelines). Alternatively, if
nothing depends on your Python2 package, you can just switch to Python 3
entirely.

It's ok to do this in Rawhide only, however, it would be greatly
appreciated if you could push it to Fedora 24 as well.


If anything is unclear, or if you need any kind of assistance with the
porting, you can ask on IRC (#fedora-python on Freenode), or reply here.
We'll be happy to help!


[0] https://fedoraproject.org/wiki/Packaging:Python
[1] https://fedoraproject.org/wiki/Packaging:Python#Example_common_spec_file
Comment 1 Dominika Krejčí 2016-04-20 11:10:32 EDT
Hello Maxim,

Do you need any help adding Python 3 support to the RPM?

If you need more instructions, a [guide] for porting Python-based RPMs is available.

[guide] http://python-rpm-porting.readthedocs.org/en/latest/index.html
Comment 2 Dominika Krejčí 2016-07-13 09:42:21 EDT
I have tried make a patch for specfile but the new version (2.1.2) needs packages which are not in Fedora yet:

- requests_toolbelt (https://pypi.python.org/pypi/requests-toolbelt)
- requests_oauthlib (https://github.com/requests/requests-oauthlib)
Comment 3 Jan Kurik 2016-07-26 00:40:19 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 25 development cycle.
Changing version to '25'.
Comment 4 Dominika Krejčí 2016-08-23 09:20 EDT
Created attachment 1193312 [details]
add Python 3 & update version

My mistake, the packages mentioned before are ready. There is a patch.

Maxim, could you please review it and push it?

Tested in Mock, Koji scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=15350411
Comment 5 Iryna Shcherbina 2017-03-28 11:09 EDT
Created attachment 1267007 [details]
Add Python 3 support and update to 2.2.1

Hi,

I have updated Dominika's patch to the latest upstream version (2.2.1). You may find the new patch attached. Please review it and do the update.

Please note that, although this package is built for EPEL 5 and 6 in pkgdb, flickrapi has dropped Python 2.6 support since version 2.0.1, therefore this patch is Fedora only.

Koji scratch build: https://koji.fedoraproject.org/koji/taskinfo?taskID=18647428
Comment 6 Fedora Update System 2017-03-31 10:57:37 EDT
python-flickrapi-2.2.1-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-c3bd149b09
Comment 7 Fedora Update System 2017-04-01 20:51:31 EDT
python-flickrapi-2.2.1-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-c3bd149b09
Comment 8 Fedora Update System 2017-04-05 18:00:25 EDT
python-flickrapi-2.2.1-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.