Bug 1312346 - nfs: fix lock variable type
nfs: fix lock variable type
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Prasanna Kumar Kalever
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-26 09:02 EST by Prasanna Kumar Kalever
Modified: 2016-06-16 09:58 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-16 09:58:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prasanna Kumar Kalever 2016-02-26 09:02:20 EST
Description of problem:
nfs: fix lock variable type
    
    variable 'mountlock' should be generic
    since it is used by macros LOCK_* ,
    it can be used spinlock or mutexlock

Version-Release number of selected component (if applicable):
mainline

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2016-02-27 12:38:37 EST
REVIEW: http://review.gluster.org/13532 (nfs: fix lock variable type) posted (#1) for review on master by Prasanna Kumar Kalever (pkalever@redhat.com)
Comment 2 Vijay Bellur 2016-02-29 00:56:53 EST
REVIEW: http://review.gluster.org/13532 (nfs: fix lock variable type) posted (#2) for review on master by Prasanna Kumar Kalever (pkalever@redhat.com)
Comment 3 Vijay Bellur 2016-03-17 02:30:45 EDT
REVIEW: http://review.gluster.org/13532 (nfs: fix lock variable type) posted (#3) for review on master by Prasanna Kumar Kalever (pkalever@redhat.com)
Comment 4 Vijay Bellur 2016-03-17 11:21:16 EDT
COMMIT: http://review.gluster.org/13532 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit a6aecae2cd8171b8538bfe5d2800bdd157380b85
Author: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>
Date:   Fri Feb 26 19:28:58 2016 +0530

    nfs: fix lock variable type
    
    variable 'mountlock' should be generic
    since it is used by macros LOCK_* ,
    it can be used spinlock or mutexlock
    
    Change-Id: If558bcf8debd98c4e1a615df0f9f0caec586e39b
    BUG: 1312346
    Signed-off-by: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>
    Reviewed-on: http://review.gluster.org/13532
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
Comment 5 Mike McCune 2016-03-28 19:22:56 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 6 Niels de Vos 2016-06-16 09:58:44 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.