Bug 1312354 - changelog: fix typecasting of function
changelog: fix typecasting of function
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: changelog (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Prasanna Kumar Kalever
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-26 09:17 EST by Prasanna Kumar Kalever
Modified: 2016-06-16 09:58 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-16 09:58:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prasanna Kumar Kalever 2016-02-26 09:17:04 EST
Description of problem:
changelog: fix typecasting of function
                                                                                
fix compiler error:                         
"error: void value not ignored as it ought to be"
                                                                                
while the code tries to typecast return type of                            
'LOCK_DESTROY(lock)' to (void)

Version-Release number of selected component (if applicable):
mainline

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2016-02-27 12:40:35 EST
REVIEW: http://review.gluster.org/13533 (changelog: fix typecasting of function) posted (#1) for review on master by Prasanna Kumar Kalever (pkalever@redhat.com)
Comment 2 Vijay Bellur 2016-02-29 00:56:50 EST
REVIEW: http://review.gluster.org/13533 (changelog: fix typecasting of function) posted (#2) for review on master by Prasanna Kumar Kalever (pkalever@redhat.com)
Comment 3 Vijay Bellur 2016-03-17 02:30:42 EDT
REVIEW: http://review.gluster.org/13533 (changelog: fix typecasting of function) posted (#3) for review on master by Prasanna Kumar Kalever (pkalever@redhat.com)
Comment 4 Vijay Bellur 2016-03-17 11:22:16 EDT
COMMIT: http://review.gluster.org/13533 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit d8ec29ae63b2efeed5da3252b4e468e07f9de4a8
Author: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>
Date:   Fri Feb 26 19:34:38 2016 +0530

    changelog: fix typecasting of function
    
    fix compiler error:
    "error: void value not ignored as it ought to be"
    
    while the code tries to typecast return type of
    'LOCK_DESTROY(lock)' to (void)
    
    Change-Id: I38ed47f3a12719c7a4a59388c0d021858d4dfe6d
    BUG: 1312354
    Signed-off-by: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>
    Reviewed-on: http://review.gluster.org/13533
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
Comment 5 Mike McCune 2016-03-28 19:22:56 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 6 Niels de Vos 2016-06-16 09:58:44 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.