Bug 1312361 - undercloud.qcow2.md5 should not contain absolute path
undercloud.qcow2.md5 should not contain absolute path
Status: CLOSED NOTABUG
Product: RDO
Classification: Community
Component: rdo-manager (Show other bugs)
trunk
Unspecified Unspecified
unspecified Severity unspecified
: ---
: Kilo
Assigned To: Hugh Brock
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-26 09:26 EST by Sandro Mathys
Modified: 2016-04-18 03:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-02 07:09:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sandro Mathys 2016-02-26 09:26:39 EST
As documented at [1], it's a good idea to verify the md5sum of the downloaded undercloud image. However, when executing `md5sum -c undercloud.qcow2.md5`, the check will fail:

[root@rdo mitaka]# md5sum -c undercloud.qcow2.md5
md5sum: /tmp/oooq-images/undercloud.qcow2: No such file or directory
/tmp/oooq-images/undercloud.qcow2: FAILED open or read

This is, because the undercloud.qcow2.md5 file [2] includes an absolute path after the checksum:

6c7dc0e0b14b7b3deff0da284594d778  /tmp/oooq-images/undercloud.qcow2

Instead of just the file name as expected, like this:

6c7dc0e0b14b7b3deff0da284594d778  undercloud.qcow2

---

[1] https://www.rdoproject.org/rdo-manager/
[2] https://ci.centos.org/artifacts/rdo/images/mitaka/delorean/stable/undercloud.qcow2.md5
Comment 1 Sandro Mathys 2016-03-02 07:09:14 EST
Reported against tripleo-quickstart instead:
https://github.com/redhat-openstack/tripleo-quickstart/issues/7

Note You need to log in before you can comment on or make changes to this bug.