Bug 131237 - Bad: unable to clone fc2 diskdrive - ghost reports "read error failures"
Bad: unable to clone fc2 diskdrive - ghost reports "read error failures"
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2004-08-30 07:48 EDT by WSchleicher
Modified: 2008-05-09 13:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-10-07 15:04:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description WSchleicher 2004-08-30 07:48:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7)
Gecko/20040626 Firefox/0.8

Description of problem:
Problem with kickstart (nfs) installation & ghost diskdump with

Dear all,

there seems to be a bug when installing a core fedora (2) installation
via kickstart options. After having successfully installed fc2 (the
files are from FC2.B redhat magazin) on a blank ide-hd via nfs
(ibm-djas-220) and accessing the hd from dos/ghost network drives,
trying to clone the whole disk, Ghost (ver.8) reports "read error
failures" and stops. (I`ve tried several harddisks) The only solution
to make ghost "working" is including the ghost -IA(L) switch, which
copies all sectors of the drive but turns off any compression.

The anaconda ks-file after installation:
(options are valid for dvd & nfs install)
#bootloader --location=mbr --append rhgb quiet
#clearpart --all --initlabel
#part /boot --fstype ext3 --size=128 --asprimary
#part /vmware --fstype ext3 --size=7680
#part /transfer --fstype ext3 --size=3584
#part / --fstype ext3 --size=2048
#part /home --fstype ext3 --size=1024
#part /usr/local --fstype ext3 --size=1024
#part /var --fstype ext3 --size=1024
#part swap --size=512

##also tested: bootloader --location=mbr --append rhgb quiet --lba32

When installing the system from the original dvd, chosing the same
partitions, the same packages, the same bootloader options, ghost
successfully clones the whole disk with compression (Z9) without
reporting any errors. 

Sine I´ve noticed certain problems around fc2 with its diskdrive
geometry (C/H/S) affecting dual boot systems, I´ve tried some ot the
offered solutions without any success (...sfdisk --no-reread -H255

Meanwhile, I´ve changed varios BIOS settings, concerning the hd-params:

The manufactors´ hd-disklabel reports: Cyl 16383, Hds 16, Sec 63
The bios reports (auto): Cyl 17475, Hds 15, Sec 63
Changed the C/H/S params to user and took the hd-disklabel settings..
LBA is turned on/off..

"Playing" with auto/user defined bios settings seem to make no
difference at all. The linux systems always boots as expected but
again and again I´m entering the same ghost error messages as
mentioned above!

Even "linux ks=nfs:<ip server>:/<folder>/ks-test.cfg hda=17475,15,63
or whatever is put after the hda options doesn´t change anything.

Is this a known bug in FC2?

In RH9 the nfs kickstart installation and ghost are working without
any problems.

Kind regards,
Wolfgang Schleicher

Version-Release number of selected component (if applicable):
kernel-2.6.6-1.435.2.1 (i686)

How reproducible:

Steps to Reproduce:
Installation of fedora core (2) system via kickstart nfs (ca. 1.4GB
data) on various disks with different bootloader options and
partitions tables!

Actual Results:  Trying to clone the entire disk with ghost and
enabled compression, always entering the same ghost read-failure messages!

Expected Results:  Succesfully cloning the disk with ghost and enabled
compression as it is actually working with RH9.

Additional info:
Comment 1 Jeremy Katz 2004-08-30 11:36:49 EDT
Unfortunately, this is a problem with ghost and can't be debugged by
us as we don't have the source to it.  There are new features
available for ext3 in the 2.6 kernel that they probably don't
Comment 2 WSchleicher 2004-08-30 13:37:45 EDT
Maybe there´s must be a misunderstanding. As I tried to explain before
ghost works perfectly if the fedora core 2 installation is done from
the fc2 dvd. Symantec´s diskclone just "fails", if the (identic)
fedora core 2 installation is done by the kickstart-method. 

The result is always reproduceable: ghost is "Checking directory
structures...", "Creating image with compression..." and then, just
after a few seconds, (you can hear the noise while ghost is trying to
access the disk) aborts with the error messages as desribed before.
The kickstart´s nfs sourcefiles have been copied from the fc2 dvd.

So the fedora install-program (or whatever) must be working different
if the installation is started with the kickstart-method!

There can be no doubt that in this case symantec´s ghost can´t be
blamed for. (officially, ghost 8 supports ext3 linux filesystems)

Kind regards,
Wolfgang Schleicher

Note You need to log in before you can comment on or make changes to this bug.