Bug 1312376 - Failures in the GOLD testsuite show up as problems in rpmdiff
Failures in the GOLD testsuite show up as problems in rpmdiff
Status: CLOSED ERRATA
Product: Red Hat Developer Toolset
Classification: Red Hat
Component: binutils (Show other bugs)
DTS 4.1 RHEL 7
All All
unspecified Severity low
: beta1
: 4.1
Assigned To: Nick Clifton
Miloš Prchlík
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-26 10:04 EST by Nick Clifton
Modified: 2016-05-31 04:43 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes Only
Doc Text:
Cause: Bugs in the GOLD linker testsuite (from the rebased 2.25.1 sources) lead to 10 failures being reported for that testsuite. Consequence: Rpmdiff registers a problem because of the new failures. Fix: Correct mistakes in the GOLD testsuite. Result: No reported failures for the GOLD testsuite.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-31 04:43:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (7.77 KB, patch)
2016-02-26 10:04 EST, Nick Clifton
no flags Details | Diff

  None (edit)
Description Nick Clifton 2016-02-26 10:04:09 EST
Created attachment 1130855 [details]
Proposed patch

Description of problem:

The GOLD testsuite produces 10 failures with the current DTS 4.1 sources.
These trigger an exception when the rpmdiff tool is used to examine a DTS build.


Version-Release number of selected component (if applicable):

2.25.1

How reproducible:

100%

Steps to Reproduce:
1. Run the gold testsuite.
2.
3.

Actual results:

10 of 213 tests failed
See testsuite/test-suite.log

Expected results:

No failures

Additional info:

Proposed patch attached.
Comment 2 Nick Clifton 2016-03-02 06:43:56 EST
Patch added to rpm.
Comment 4 Miloš Prchlík 2016-04-19 08:37:02 EDT
Verified for build devtoolset-4-binutils-2.25.1-10.el7.
Comment 6 errata-xmlrpc 2016-05-31 04:43:40 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1148

Note You need to log in before you can comment on or make changes to this bug.