Bug 1312416 - When editing configs or routes via the OSE web console, from Internet Explorer 11, the editor does not paste the contents of the clipboard.
When editing configs or routes via the OSE web console, from Internet Explore...
Status: CLOSED NOTABUG
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console (Show other bugs)
3.1.0
Unspecified Unspecified
high Severity low
: ---
: ---
Assigned To: Jessica Forrester
yapei
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-26 11:16 EST by Miheer Salunke
Modified: 2016-11-09 08:24 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-09 08:24:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
PasteContentToEditor (386.49 KB, image/png)
2016-04-07 06:13 EDT, yapei
no flags Details
Versions (304.90 KB, image/png)
2016-04-07 06:13 EDT, yapei
no flags Details

  None (edit)
Description Miheer Salunke 2016-02-26 11:16:29 EST
Description of problem:
When editing configs or routes via the OSE web console, from Internet Explorer 11, the editor does not paste the contents of the clipboard.

Version-Release number of selected component (if applicable):
Openshift Enterprise 3.1.1
Internet Explorer 11.0.9600.18163
Screenshot in attachment.

How reproducible:
Always

Steps to Reproduce:
1. Paste clipboard content via context menu or shortcuts (CTRL+V or Shift+Insert) .
2.
3.

Actual results:
Not able to paste clipboard content via context menu or shortcuts (CTRL+V or Shift+Insert)

Expected results:
Should be able to paste clipboard content via context menu or shortcuts (CTRL+V or Shift+Insert)

Additional info:
Comment 1 Jessica Forrester 2016-02-26 12:13:19 EST
We are unable to reproduce this. Is there a particular version of windows they are seeing it on?  Are they running in intranet compatibility mode or using a different document mode?
Comment 4 yapei 2016-03-02 20:30:20 EST
Tried on OSE-3.1.1.6 with IE 11.103.10586.0

1. copied some content from Notepad txt
2. create app on web console
3. on Browse->Routes page, Click "edit(Raw)"
4. in the editor, 
try CTRL +V 
try Shift + Insert 
try Right Click on mouse -> Paste

all options could work well
Comment 8 yapei 2016-04-07 06:13 EDT
Created attachment 1144649 [details]
PasteContentToEditor
Comment 9 yapei 2016-04-07 06:13 EDT
Created attachment 1144650 [details]
Versions
Comment 17 Jessica Forrester 2016-11-09 08:24:01 EST
Closing as not a bug since the root cause was an IE security setting that prevented pasting:

In IE 11 go to Tools -> Internet Options -> Security -> Custom Level and then look for Allow Programmatic Clipboard Access  the default setting for this in IE is Prompt, if it is set to Prompt or Enabled then pasting into the editor works as expected, if this setting is set to Disabled then you will not be able to paste into the editor.

Note You need to log in before you can comment on or make changes to this bug.