This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 131242 - Cannot add png||jpg desktop background using gnome-background-properties
Cannot add png||jpg desktop background using gnome-background-properties
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
David Lawrence
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-08-30 08:55 EDT by James Laska
Modified: 2013-09-02 01:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-01 09:59:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James Laska 2004-08-30 08:55:50 EDT
# TREE rawhide-20040830
# RPMS control-center-2.7.1-1
       gnome-libs-1.4.1.2.90-41

Steps to reproduce:
 1) right click on desktop and select "Change Desktop Background"
 2) select "Add Wallpaper"
 3) navigate to png or jpg and select that image

Actual Results:
 - The selected image does not show up in the above file display

Expected Results:
 - The selected image should appear in the background file display and
should be selected as the current background.

I should note that I can open up the image in epiphany and right click
"Set as background" and that works correctly.  I believe this bug is
related to bug#131113.  I can remove an image that is already in my
background list, and re-add it.  Shown below are the results of `file`
on the image that I removed/then added again (existing.jpg), and one
of many new images that won't add to the list (new.jpg).

(~/Desktop/Documents/Images)> file existing.jpg
existing.jpg: JPEG image data, EXIF standard 2.2

(~/Desktop/Documents/Images)> file new.jpg
new.jpg: JPEG image data, EXIF standard 2.2

I am attaching `strace` output from an attempt to add a background to
my list.
Comment 1 James Laska 2004-08-30 09:03:55 EDT
For a full strace (1.4M) of the above scenario (attempting to add a
new image "Big Sur Sunset.jpg") see ...

http://people.redhat.com/jlaska/gbp.strace
Comment 2 James Laska 2004-09-01 09:59:32 EDT
Closed not a bug ... adding the gamin package seems to have resolved
the issue.

Note You need to log in before you can comment on or make changes to this bug.