Bug 1312424 - bootstrapping nodes for the first time has SSH issues
Summary: bootstrapping nodes for the first time has SSH issues
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: ceph-installer
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 2
Assignee: Alfredo Deza
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-02-26 16:34 UTC by Alfredo Deza
Modified: 2017-01-25 21:37 UTC (History)
11 users (show)

Fixed In Version: ceph-installer-1.0.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:31:25 UTC
Target Upstream Version:
icolle: needinfo+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2889071 None None None 2017-01-25 21:37:16 UTC
Red Hat Product Errata RHBA-2016:1755 normal SHIPPED_LIVE Red Hat Ceph Storage 2.0 bug fix and enhancement update 2016-08-23 23:23:52 UTC

Description Alfredo Deza 2016-02-26 16:34:57 UTC
Description of problem:


It wants to perform a host key verification because the user has never SSH'd in before:

vagrant@vagrant:/opt/ceph-installer/ceph-ansible$ whoami
vagrant
vagrant@vagrant:/opt/ceph-installer/ceph-ansible$ curl localhost:8080/setup/ | sudo bash
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  1010  100  1010    0     0    492      0  0:00:02  0:00:02 --:--:--   492
--> creating new user with disabled password: ceph-installer
useradd: user 'ceph-installer' already exists
passwd: password expiry information changed.
--> adding provisioning key to the ceph-installer user authorized_keys
--> ensuring correct permissions on .ssh/authorized_keys
--> ensuring that ceph-installer user will be able to sudo
--> ensuring ceph-installer user does not require a tty
vagrant@vagrant:/opt/ceph-installer/ceph-ansible$ ssh ceph-installer@localhost
The authenticity of host 'localhost (::1)' can't be established.
ECDSA key fingerprint is 15:26:b9:5d:50:8d:8f:7e:83:f3:3d:28:8d:b6:8a:6c.
Are you sure you want to continue connecting (yes/no)? no
Host key verification failed.




Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1. run the bootstrap script on a client
2. try to ssh from the ceph-installer host to the remote host (client)
3.

Actual results:


Expected results:
No prompts, successful ssh login


Additional info:

Comment 5 Mike McCune 2016-03-28 22:11:59 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 9 Rachana Patel 2016-08-01 21:12:14 UTC
verified with - ceph-installer-1.0.14-1.el7scon.noarch

Comment 11 errata-xmlrpc 2016-08-23 19:31:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1755


Note You need to log in before you can comment on or make changes to this bug.