Bug 1312427 - Vinagre segfault due memory allocation
Vinagre segfault due memory allocation
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vinagre (Show other bugs)
6.8
i386 Linux
unspecified Severity high
: rc
: ---
Assigned To: Marek Kašík
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-26 11:42 EST by Vaclav Ehrlich
Modified: 2016-11-01 06:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-01 06:33:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vinagre segfault while connecting to VNC (6.83 KB, text/plain)
2016-02-26 11:42 EST, Vaclav Ehrlich
no flags Details

  None (edit)
Description Vaclav Ehrlich 2016-02-26 11:42:10 EST
Created attachment 1130863 [details]
vinagre segfault while connecting to VNC

Description of problem:
This was really strange segfault, because occurred in test case launched many times before. Virtual Machine had just two days uptime.
I've started Vinagre, connected to RDP machine and then I opened VNC connection to localhost (:1)
This crashed Vinagre. 
After that it was unable to connect any protocol.

Result from gdb are in attachment 

Version-Release number of selected component (if applicable):
vinagre-2.28.1-9.el6.i686

How reproducible:
Now investigating ...

Steps to Reproduce:
1.have RDP host prepared and local VNC server on port 5901
2.Open Vinagre
3.Connect to RDP host (RDP protocol, IP address, username and domain filled) 
4.Connect to VNC host (VNC procotol, :1 as 

Actual results:
Vinagre received signal SIGSEGV and ends

Expected results:
VNC connection is opened

Additional info:
Comment 2 Marek Kašík 2016-02-29 05:43:47 EST
It looks like the machine doesn't have enough free memory. Could you identify which application is consuming such amount of it? Is it Vinagre? (I don't see such behaviour with my quick test in a VM)
Comment 6 RHEL Product and Program Management 2016-11-01 06:33:02 EDT
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.