Bug 1312458 - rpm_finder functionality bypassed for missing debuginfo
rpm_finder functionality bypassed for missing debuginfo
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemtap (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Frank Ch. Eigler
Martin Cermak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-26 13:10 EST by Frank Ch. Eigler
Modified: 2016-11-04 00:36 EDT (History)
5 users (show)

See Also:
Fixed In Version: systemtap-3.0-2.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 00:36:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Ch. Eigler 2016-02-26 13:10:59 EST
Without a $FOO-debuginfo installed, stap -p4 no longer advises what RPMs should be installed to fill the gap.  We get only a

semantic error: missing $ARCH kernel/module debuginfo [man warning::debuginfo] under '/lib/modules/$VERREL/build'

line, and misses of the goods rpm_finder.cxx is supposed to show.
Comment 2 Frank Ch. Eigler 2016-02-29 12:07:37 EST
upstream commit #dae1c685cfd41d544
Comment 9 errata-xmlrpc 2016-11-04 00:36:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2358.html

Note You need to log in before you can comment on or make changes to this bug.