This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1312498 - RFE: noauto mount option for /boot/efi as anaconda default
RFE: noauto mount option for /boot/efi as anaconda default
Status: CLOSED DUPLICATE of bug 1077984
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
24
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-26 17:32 EST by Noel McLoughlin
Modified: 2016-02-29 09:26 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-29 09:26:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Noel McLoughlin 2016-02-26 17:32:03 EST
Description of problem:

Consider setting /boot/efi 'noauto' mount option as anaconda install default. Runtime access is only required during certain administrative operations.


Version-Release number of selected component (if applicable):

# rpm -q grubby
grubby-8.40-3.fc24.x86_64

# rpm -q anaconda
anaconda-24.11-1.fc24.x86_64

How reproducible:

Steps to Reproduce:
1. vi /etc/fstab
2. Add 'noauto' mount option to /etc/efi
3. umount /boot/efi

Actual results:

N/A

Expected results:

# grubby --update-kernel=ALL --args="console=ttyS0" --config-file=/boot/efi/EFI/fedora/grub.cfg
error opening /boot/efi/EFI/fedora/grub.cfg for read: No such file or directory

Additional info:
Comment 1 Noel McLoughlin 2016-02-26 17:33:20 EST
During administrative operations, /boot/efi can be mounted manually.

# mount /boot/efi
Comment 2 Kamil Dudka 2016-02-27 07:46:01 EST
The some applies to /boot, does not it?

Anyway, how is this related to the basesystem package?
Comment 3 Noel McLoughlin 2016-02-27 10:58:52 EST
I understand arguments for/against (see https://github.com/systemd/systemd/issues/2402) and would dislike this enhancement in Enterprise Linux, but think it should be considered in Fedora as consumer distro.
Comment 4 David Shea 2016-02-29 09:26:29 EST

*** This bug has been marked as a duplicate of bug 1077984 ***

Note You need to log in before you can comment on or make changes to this bug.