Bug 1312500 - Incorrect rendering (overlapping characters) of some character combinations involving diacritics(?)
Incorrect rendering (overlapping characters) of some character combinations i...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: abattis-cantarell-fonts (Show other bugs)
rawhide
All All
unspecified Severity high
: ---
: ---
Assigned To: Fabio Alessandro Locati
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-26 17:38 EST by Adam Williamson
Modified: 2016-05-28 10:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-28 10:21:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2016-02-26 17:38:36 EST
So we'll need to do a bit more triage on this one, but I'm busy right now so just want to file it. Today's openQA French install test for Rawhide failed. The failure seems to be caused by some messed-up rendering of particular character combinations. Here's the failed step:

https://openqa.fedoraproject.org/tests/6079/modules/_do_install_and_reboot/steps/18

Note the incorrect rendering of the message above the "Redémarrer" (reboot) button, which is:

"Fedora est maintenant installé avec succès et est prêt à être utilisé !"

This text contains the two character sequence "êt" twice, and both times, it is incorrectly rendered - the characters are overlapped.

A similar issue can be observed on the main hub:

https://openqa.fedoraproject.org/tests/6079/modules/disk_guided_empty/steps/4

with the text "NOM D'HÔTE ET RÉSEAU" - the ÔT sequence is similarly incorrectly rendered.

As I'm writing this bug report, I've become pretty sure the bug is in Cantarell. If I paste the text êt into gedit (where my font is DejaVu Sans Mono) it renders fine. If I then change gedit's font to Cantarell it displays incorrectly (overlapped, like in the screenshots). If I change to another proportional font it also renders fine. So this seems like an error in cantarell. It also affects â and ô and ü and Ô and a few others, but not î or û. In gucharmap the affected characters actually display off-centre within the boxes in the character table, so you can see which characters are affected quite easily. Basically it seems like these characters are not correctly placed in the glyph grid or whatever it's called - they're nearly a whole character's width to the right of where they should be.
Comment 1 Adam Williamson 2016-02-26 17:46:22 EST
Hmm, this is odd: the last build of abattis-cantarell-fonts was 2016-02-17, and this test has definitely passed in openQA since then, indicating the bug wasn't happening (I see a pass as late as 2016-02-22, and I just checked the 2016-02-22 Rawhide repo and it definitely has abattis-cantarell-fonts-0.0.22-1.fc24.noarch.rpm, the latest build.

So *something* else must have changed between 2016-02-22 and now which somehow affects rendering of abattis but not any other font I've checked, but I can't see what that would be...neither freetype nor pango has changed in that time. GTK+ 3.19.10 landed on 2016-02-24, that's the only thing I can think of that could somehow possibly be involved?
Comment 2 Adam Williamson 2016-02-26 18:07:14 EST
Thanks to zaitor (Bjørn Lie):

<zaitor> adamw: that is already fixed upstream, get the new version
<zaitor>  cantarell-fonts 0.0.23 - reworked anchors for correct accent rendering under harfbuzz 1.2.0

the fix is https://git.gnome.org/browse/cantarell-fonts/commit/?id=434a116b0941cd794e6eec0613b7479d2c96503e , it seems, and cantarell 0.0.23 will fix this. I've sent 0.0.23 builds for Rawhide and F24 now.
Comment 3 Fedora Admin XMLRPC Client 2016-04-10 03:37:19 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Fabio Alessandro Locati 2016-05-28 09:54:02 EDT
@Adam Williamson: This should be fixed now. Is this correct?
Comment 5 Adam Williamson 2016-05-28 10:21:32 EDT
Oh, yeah, ages ago.

Note You need to log in before you can comment on or make changes to this bug.