Bug 1312578 - gdal needs rebuilding against changed mysql client library
gdal needs rebuilding against changed mysql client library
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gdal (Show other bugs)
25
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Devrim GÜNDÜZ
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-27 09:55 EST by Tom Hughes
Modified: 2017-09-11 15:03 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-11 15:03:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Hughes 2016-02-27 09:55:28 EST
It seems there was been a symbol versioning change in libmysqlclient that requires a rebuild of gdal:

rawhide [~] % psql -c 'CREATE EXTENSION postgis' template_postgis
ERROR:  could not load library "/usr/lib64/pgsql/rtpostgis-2.2.so": /lib64/libgdal.so.20: symbol mysql_use_result, version libmysqlclient_16 not defined in file libmysqlclient.so.18 with link time reference
Comment 1 Tom Hughes 2016-02-27 09:56:00 EST
Note that this likely needs doing in F24 as well.
Comment 2 Volker Fröhlich 2016-02-27 11:13:41 EST
We had gdal builds on 2016-02-21. As far as I can see, that's after the latest update of mariadb.
Comment 3 Tom Hughes 2016-02-27 11:26:01 EST
Well something seems to be broken...

I admit to being a bit confused because my examination of libmysqlclient.so.18 suggested it was exposing two versions of mysql_use_result, one versioned as libmysqlclient_18 and one versioned as libmysqlclient_16.

That ought to mean that either version is available to the dynamic linker for symbol resolution at run time even if only the newer one is available for new links.

Certainly ldd reports multiple problems if you ask it to check the relocations:

rawhide [~] % ldd -r /lib64/libgdal.so.20
symbol mysql_use_result, version libmysqlclient_16 not defined in file libmysqlclient.so.18 with link time reference	(/lib64/libgdal.so.20)
symbol mysql_real_connect, version libmysqlclient_16 not defined in file libmysqlclient.so.18 with link time reference	(/lib64/libgdal.so.20)
symbol mysql_errno, version libmysqlclient_16 not defined in file libmysqlclient.so.18 with link time reference	(/lib64/libgdal.so.20)
symbol mysql_close, version libmysqlclient_16 not defined in file libmysqlclient.so.18 with link time reference	(/lib64/libgdal.so.20)
symbol mysql_init, version libmysqlclient_16 not defined in file libmysqlclient.so.18 with link time reference	(/lib64/libgdal.so.20)
symbol mysql_query, version libmysqlclient_16 not defined in file libmysqlclient.so.18 with link time reference	(/lib64/libgdal.so.20)
symbol mysql_free_result, version libmysqlclient_16 not defined in file libmysqlclient.so.18 with link time reference	(/lib64/libgdal.so.20)
symbol mysql_num_fields, version libmysqlclient_16 not defined in file libmysqlclient.so.18 with link time reference	(/lib64/libgdal.so.20)
symbol mysql_field_seek, version libmysqlclient_16 not defined in file libmysqlclient.so.18 with link time reference	(/lib64/libgdal.so.20)


I seem to have the latest gdal and mariadb-libs (though I first saw this in koji anyway):

gdal-2.0.2-4.fc24.x86_64
mariadb-libs-10.1.11-8.fc24.x86_64
Comment 4 Jan Kurik 2016-07-26 00:13:22 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 25 development cycle.
Changing version to '25'.
Comment 5 Volker Fröhlich 2016-12-20 15:41:39 EST
Whatever caused this situation, the problem appears to be resolved in F24 and F25. Can we close it?
Comment 6 Rex Dieter 2017-09-11 15:03:50 EDT
closing per comment #5

Note You need to log in before you can comment on or make changes to this bug.