Bug 1312584 - Missing python-urllib3 requires
Missing python-urllib3 requires
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-elasticsearch (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Piotr Popieluch
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-27 10:41 EST by Jeff Peeler
Modified: 2016-06-20 16:25 EDT (History)
2 users (show)

See Also:
Fixed In Version: python-elasticsearch-2.3.0-1.fc24 python-elasticsearch-1.7.0-2.fc22 python-elasticsearch-1.7.0-2.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-18 14:35:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Peeler 2016-02-27 10:41:21 EST
I was going through the example program on http://elasticsearch-py.readthedocs.org/en/master/index.html and got this:

[root@4df6100d3e44 elastic]# ./dbtest.py 
Traceback (most recent call last):
  File "./dbtest.py", line 3, in <module>
    from elasticsearch import Elasticsearch
  File "/usr/lib/python2.7/site-packages/elasticsearch/__init__.py", line 17, in <module>
    from .client import Elasticsearch
  File "/usr/lib/python2.7/site-packages/elasticsearch/client/__init__.py", line 5, in <module>
    from ..transport import Transport
  File "/usr/lib/python2.7/site-packages/elasticsearch/transport.py", line 5, in <module>
    from .connection import Urllib3HttpConnection
  File "/usr/lib/python2.7/site-packages/elasticsearch/connection/__init__.py", line 3, in <module>
    from .http_urllib3 import Urllib3HttpConnection
  File "/usr/lib/python2.7/site-packages/elasticsearch/connection/http_urllib3.py", line 2, in <module>
    import urllib3
ImportError: No module named urllib3

After installing python-urllib3 manually everything worked fine. The requirement was present in 1.7.0 (and is still present):

https://github.com/elastic/elasticsearch-py/blob/14f5b35a2339440332391b9c180f1f7ddfaf8799/setup.py#L16
Comment 1 Piotr Popieluch 2016-06-08 15:03:35 EDT
I removed it because of this error rpmlint gave me:

python-elasticsearch.noarch: E: explicit-lib-dependency python-urllib3
Comment 2 Jeff Peeler 2016-06-08 15:14:45 EDT
I know the warning is annoying, but sometimes the warnings rpmlint gives is misleading. I assume you'll put it back when you get a chance.
Comment 3 Piotr Popieluch 2016-06-08 15:37:37 EDT
Yes, it seems that the "error" is caused because of rpmlint simple checks if the requires contain a string 'lib' :S

Readding the require and opening a bug on rpmlint.

Thanks for pointing it out.
Comment 4 Jeff Peeler 2016-06-08 15:53:04 EDT
No problem.

You may not want to bother filing a bug with rpmlint:

https://bugzilla.redhat.com/show_bug.cgi?id=790869
Comment 5 Fedora Update System 2016-06-08 16:09:22 EDT
python-elasticsearch-2.0.0-4.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-30de903c4a
Comment 6 Fedora Update System 2016-06-08 16:30:14 EDT
python-elasticsearch-1.7.0-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-62abbd9345
Comment 7 Fedora Update System 2016-06-08 16:31:04 EDT
python-elasticsearch-1.7.0-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-d4d8764395
Comment 8 Fedora Update System 2016-06-09 12:55:50 EDT
python-elasticsearch-2.0.0-4.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-30de903c4a
Comment 9 Fedora Update System 2016-06-09 13:29:55 EDT
python-elasticsearch-2.3.0-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-830b0de4a4
Comment 10 Fedora Update System 2016-06-09 23:24:10 EDT
python-elasticsearch-1.7.0-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-d4d8764395
Comment 11 Fedora Update System 2016-06-09 23:57:05 EDT
python-elasticsearch-1.7.0-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-62abbd9345
Comment 12 Fedora Update System 2016-06-10 14:00:49 EDT
python-elasticsearch-2.3.0-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-830b0de4a4
Comment 13 Fedora Update System 2016-06-18 14:35:29 EDT
python-elasticsearch-2.3.0-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2016-06-20 16:19:40 EDT
python-elasticsearch-1.7.0-2.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2016-06-20 16:25:00 EDT
python-elasticsearch-1.7.0-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.