This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1312588 - allegro5-5.0.3 outdated
allegro5-5.0.3 outdated
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: allegro5 (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-27 11:57 EST by Stas Sergeev
Modified: 2016-03-11 08:28 EST (History)
2 users (show)

See Also:
Fixed In Version: allegro5-5.0.11-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-11 08:28:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stas Sergeev 2016-02-27 11:57:22 EST
Description of problem:
allegro5-5.0.3 was released 5 years ago.
It is not enough to build modern games, see for instance here:
https://github.com/oitofelix/mininim/issues/7
Please upgrade to 5.0.11 (latest stable, by the time of writing this)
or maybe even to 5.1.x.

Version-Release number of selected component (if applicable):
allegro5-5.0.3

How reproducible:
easily

Steps to Reproduce:
1. rpm -q allegro5

Actual results:
Old allegro

Expected results:
New allegro

Additional info:
Comment 1 Brandon McCaig 2016-02-28 03:30:19 EST
This is a legitimate request. 5.0.3 was one of the earliest releases after a major rewrite of the library and was followed by very many bug fixes and even features. At this point in time, 5.1.x is probably the better option in my opinion. I've heard that it has many more features and many more bug fixes at this point. It is considered the "unstable" branch, which basically just means there's no guarantee that the developers won't break the API, but it's probably worth that risk to get the bug fixes and extra features. And I don't think the developers change the API often, if at all. I'm not sure if that will align with Fedora's packaging standards.

Note, the reason this package hasn't been updated in so many years is because I never really got the hang of packaging. This was my first and only package and I didn't fully grasp the process. I only remember bits and pieces of it now. I'm not sure how long this will take me to do again. I haven't even been running Fedora in years. If you or anyone else wishes to take over the package that's fine by me. Otherwise, I'll do my best to figure out the process again and update the package... Not sure if I'll need a mentor again. I will need to seriously brush up on packaging procedures and the like...
Comment 2 Brandon McCaig 2016-02-28 03:52:00 EST
Correction: I chatted briefly with one of the devs ("SiegeLord") on IRC and he discourages packaging only 5.1.x. To play it safe we should probably stick to 5.0.x, which unfortunately means that people that want the latest features will still need to build from source (honestly it's not that hard though). It probably aligns better with Fedora's packaging standards to package stable anyway... I wonder if we could create a new set of packages for the "unstable" branch side-by-side... I believe there is a small effort to release a stable 5.2.x release in the future, which will be worth packaging when the time comes...
Comment 3 Hans de Goede 2016-02-28 05:08:22 EST
(In reply to Brandon McCaig from comment #2)
> Correction: I chatted briefly with one of the devs ("SiegeLord") on IRC and
> he discourages packaging only 5.1.x. To play it safe we should probably
> stick to 5.0.x, which unfortunately means that people that want the latest
> features will still need to build from source (honestly it's not that hard
> though). It probably aligns better with Fedora's packaging standards to
> package stable anyway... I wonder if we could create a new set of packages
> for the "unstable" branch side-by-side... I believe there is a small effort
> to release a stable 5.2.x release in the future, which will be worth
> packaging when the time comes...

+1 for updating to the latest 5.0.x
Comment 4 Hans de Goede 2016-02-29 12:08:18 EST
Taking this bug, I'm preparing an update to 5.0.11 now.
Comment 5 Fedora Update System 2016-02-29 14:34:51 EST
allegro5-5.0.11-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-976ee65331
Comment 6 Fedora Update System 2016-03-02 07:53:20 EST
allegro5-5.0.11-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-976ee65331
Comment 7 Fedora Update System 2016-03-11 08:28:18 EST
allegro5-5.0.11-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.