Bug 13126 - RFE: Configure IDE-CDRW
Summary: RFE: Configure IDE-CDRW
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-27 17:13 UTC by giulioo
Modified: 2007-04-18 16:27 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-20 00:02:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description giulioo 2000-06-27 17:13:34 UTC
This is a spin-off of #12188, which I've closed because I used a too
generic summary, and it is now obsolete with beta2.

This bug is filed under "installer", but it refers to "kernel" too.

Summary of ide-cdrw problems:
The IDE CD-RW was detected as a simple CDROM, moreover the ide-cd is not
a module so you need to add lilo options during install or after the 1st 
boot. If ide-cd was a module you could just put the config info
("option ide-cd ignore hdX") in /etc/modules.conf.

Comment 1 giulioo 2000-07-11 12:08:49 UTC
Beta 3 has ide-cd as module, so I could configure the cd-rw without rebooting.
This is very good :)

However, the install (this time I used GUI since it works for me now) still 
configures it as a simple cdrom.

Bugzilla is forcing me to change the component ("installer" seems gone).
So I'm choosing anaconda, even because this time I used the GUI install.

Comment 2 Glen Foster 2000-07-30 17:35:05 UTC
Is this behavior reproducible in Pinstripe (beta-5)?

Comment 3 giulioo 2000-08-01 20:14:33 UTC
Pinstripe still detects my ide cdrw as and ide-cdrom.

mount /mnt/cdrom
loads ide-cd.

There is nothing in /etc/modules.conf to set it up as an ide cdrw
I generally use
options ide-cd ignore=hdX
and then modprobe ide-scsi in init scripts.


I could go on and "modprobe ide-scsi" but then it would take over my ls120 too, 
unless it's already in use, and however the cd would then be /dev/scd0, so it 
would be necessary to redo the /dev/cdrom link which install creates pointing 
to an ide device.



Comment 4 Michael Fulbright 2000-08-17 20:55:08 UTC
Added as a feature request to more completely configure IDE CDRW.

Comment 5 Michael Fulbright 2000-09-26 16:09:39 UTC
Moving to RESOVLED - DEFERRED from CLOSED - DEFERRED

Comment 6 Michael Fulbright 2000-09-26 16:55:21 UTC
Moving to RESOVLED - DEFERRED from CLOSED - DEFERRED

Comment 7 Michael Fulbright 2001-02-14 04:08:57 UTC
Fixed in internal CVS.


Note You need to log in before you can comment on or make changes to this bug.