Bug 1312636 - Editing a running VM seems to be broken
Editing a running VM seems to be broken
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt (Show other bugs)
3.6.3.3
Unspecified Unspecified
unspecified Severity urgent (vote)
: ovirt-3.6.3
: 3.6.3.4
Assigned To: Tomas Jelinek
Ilanit Stein
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-28 05:54 EST by Ilanit Stein
Modified: 2016-03-11 02:23 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-11 02:23:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
rule-engine: blocker+
rule-engine: planning_ack+
michal.skrivanek: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)
vm_up_gurenteed_memory_changed1.png (77.96 KB, image/png)
2016-02-28 05:54 EST, Ilanit Stein
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 54144 master MERGED webadmin: edit running VM is not possible 2016-02-29 04:57 EST
oVirt gerrit 54152 ovirt-engine-3.6 MERGED webadmin: edit running VM is not possible 2016-02-29 06:58 EST
oVirt gerrit 54159 ovirt-engine-3.6.3 MERGED webadmin: edit running VM is not possible 2016-02-29 08:59 EST

  None (edit)
Description Ilanit Stein 2016-02-28 05:54:13 EST
Created attachment 1131229 [details]
vm_up_gurenteed_memory_changed1.png

Description of problem:
Edit a running VM, with some parameter/s that can be applied only on next boot,
doesn't work:

After edit VM with some parameter/s, that require VM restart,
A window titled "pending virtual machine changes" opens,
with a list of these parameter/s (screen shot attached),
but press "OK" in this window, does nothing.
The only option that work, is "Cancel".  

Version-Release number of selected component (if applicable):
rhevm-3.6.3.3-0.1

How reproducible:
100% (no matter which parameter, that require restart is changed)

Expected results:
Edit running VM with parameters, that require VM restart should be possible.
Comment 1 Ilanit Stein 2016-02-29 02:22:35 EST
Engine.log, in response to edit running VM with guaranteed memory changed:

2016-02-29 07:20:37,954 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (ajp-/127.0.0.1:8702-8) [] Field 'minAllocatedMem' can not be updated when status is 'Up'
2016-02-29 07:20:37,955 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (ajp-/127.0.0.1:8702-8) [] Field 'balloonEnabled' can not be updated when status is 'Up'
2016-02-29 07:20:37,957 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (ajp-/127.0.0.1:8702-8) [] Field 'rngDevice' can not be updated when status is 'Up'
2016-02-29 07:20:37,958 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (ajp-/127.0.0.1:8702-8) [] Field 'soundDeviceEnabled' can not be updated when status is 'Up'
2016-02-29 07:20:37,960 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (ajp-/127.0.0.1:8702-8) [] Field 'consoleEnabled' can not be updated when status is 'Up'
2016-02-29 07:20:37,961 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (ajp-/127.0.0.1:8702-8) [] Field 'virtioScsiEnabled' can not be updated when status is 'Up'
2016-02-29 07:20:37,962 WARN  [org.ovirt.engine.core.utils.ObjectIdentityChecker] (ajp-/127.0.0.1:8702-8) [] Field 'graphicsDevices' can not be updated when status is 'Up'
Comment 2 Ilanit Stein 2016-02-29 02:46:46 EST
On rhevm 3.6.3.2-0.1.el6 The Edit running VM works fine.
Therefore, the regression started on last version, rhevm 3.6.3.3-0.1
Comment 3 Ilanit Stein 2016-02-29 03:29:40 EST
Additional info:

1. For a running VM, there is no possibility to update the memory or the cpu 
meaning memory / CPU hot plug is not working (press OK on the "pending virtual machine changes")
Also if choosing apply later for these 2, and press OK, also nothing happen.   

2. ui.log is empty (no exception) and,
no exceptions on browser console (F12):
Mon Feb 29 10:26:54 GMT+200 2016 org.ovirt.engine.ui.uicompat.EnumTranslator
WARNING: trying to localize null, probable error. Exception is not thrown, returning 'N/A'
D9824060196356E77F245FF94D64811E.cache.html:24115
Comment 4 Tomas Jelinek 2016-02-29 04:35:33 EST
It is a regression caused by https://gerrit.ovirt.org/#/c/53646 with a consequence that the running vm can not be edited. The fix is a trivial one liner, proposing for 3.6.3.
Comment 5 Tomas Jelinek 2016-02-29 05:05:22 EST
not yet modified, needs some more backports
Comment 6 Tomas Jelinek 2016-02-29 07:46:34 EST
still just post...
Comment 7 Tomas Jelinek 2016-03-01 03:04:37 EST
It is a regression between 3.6.3.2 and 3.6.3.3 fixed in 3.6.3.4 -> does not need doc text.
Comment 8 Ilanit Stein 2016-03-01 03:21:25 EST
Verified on rhevm-3.6.3.4-0.1.el6.noarch

Checked change of memory (enlarge/reduce), cpu (hot plug/unplug), guaranteed memory, all work as expected.

Note You need to log in before you can comment on or make changes to this bug.