Bug 1312717 - Can not migrate virtual machine from host A to host B with error message.( Error: Could not connect to peer host)
Can not migrate virtual machine from host A to host B with error message.( Er...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.5.7
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: nobody nobody
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-28 22:46 EST by Yoshinori Takahashi
Modified: 2016-03-09 03:17 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-09 03:17:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Yaniv Kaul 2016-02-29 02:15:08 EST
Please attach logs. Engine as well as VDSM logs from both source and destination.

I assume you've looked into possible DNS issues (for example, the destination having multiple records in DNS, some which are wrong), firewall, routing, etc.
Comment 3 Tomas Jelinek 2016-03-07 04:30:17 EST
I see couple of "java.net.NoRouteToHostException: No route to host" and "Caused by: java.rmi.ConnectException: Connection timeout" in the logs which looks like some network issues.

Can you please make sure the connection between the two hosts is indeed working when trying to migrate?
Comment 7 Tomas Jelinek 2016-03-09 03:17:34 EST
yes, something like:
telnet hostB <port>

e.g. with default port:
telnet hostB 54321

The particular port you can find in vdsm.conf as management_port.

So, closing this BZ as "not a bug", since it seems it was a networking issue.
In case it will start happening again and the networking would be OK, please feel free to reopen.

Note You need to log in before you can comment on or make changes to this bug.