Bug 1312754 - e1000 interface freeze randomly
e1000 interface freeze randomly
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipxe (Show other bugs)
7.2
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Lucas Alvares Gomes
Tzach Shefi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-29 03:22 EST by Angelo Lisco
Modified: 2016-11-03 20:38 EDT (History)
11 users (show)

See Also:
Fixed In Version: ipxe-20150821-1.git4e03af8e.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 20:38:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Angelo Lisco 2016-02-29 03:22:01 EST
Description of problem:
the e1000 driver included in the ipxe-bootimgs makes the interface freezes randomly during the download of the vmlinuz and initram files

Version-Release number of selected component (if applicable):
ipxe-bootimgs-20130517-8.gitc4bce43.el7_2.1.noarch.rpm

How reproducible:
To reproduce this bug, you have to have access on a VMware Vsphere environment

Steps to Reproduce:
1. Create a new vm on VMware Vsphere with an e1000 vNIC
2. Build an ipxe iso with static ip and configure it to download a kernel and and ram disk file in order to bootstrap the vm
3. Attach the iso and power-on the vm

Actual results:
Network interface freezes randomly during the download of the vmlinuz and initrd files

Expected results:
The vm boots without issues.

Additional info:
A patch to fix this bug was already submitted and included in the ipxe git repo on the 21/04/15:
https://git.ipxe.org/ipxe.git/commit/8958f62a1c85ff6b449a685a729b61b9ea69f50a

This patch is very important for the Satellite6/Foreman product because ipxe is used to simulate PXE-boot in case it is not available on the deployment network (and many enterprise company doesn't enable/have that).

Thanks for your attention
Comment 4 Tzach Shefi 2016-09-13 04:13:16 EDT
Verified. 

Introspected two VMware based VMs: one with a vmxnet3 nic the other with E1000 nic.  Out of 10 introspection cycles, both VMs completed introspection fine 10 out of 10 - 100% pass. 

Versions:
RHEL7.3 beta
ipxe-bootimgs-20160127-4.git6366fa7a.el7.noarch
Images-> version-10.0-20160907.1.el7ost.txt
VMware 5.5u3 
rhos-release 10 -p 2016-09-07.6
Comment 5 Raviv Bar-Tal 2016-09-27 07:37:22 EDT
Bug was verified by Tzach Shefi, on WMware lab in Tel-aviv
Comment 7 errata-xmlrpc 2016-11-03 20:38:49 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2214.html

Note You need to log in before you can comment on or make changes to this bug.