Bug 1312765 - OSPD failed to update external Ceph user
OSPD failed to update external Ceph user
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-ceph (Show other bugs)
8.0 (Liberty)
x86_64 Linux
medium Severity medium
: z3
: 10.0 (Newton)
Assigned To: Giulio Fidente
Yogev Rabl
: Triaged, ZStream
: 1361862 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-29 04:07 EST by Yogev Rabl
Modified: 2017-06-28 10:44 EDT (History)
12 users (show)

See Also:
Fixed In Version: puppet-ceph-2.3.0-2.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-28 10:44:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 406813 None None None 2017-03-17 13:12 EDT

  None (edit)
Description Yogev Rabl 2016-02-29 04:07:32 EST
Description of problem:
The external Ceph user, located on the OSP servers in /etc/ceph/... key needed an update on the running setup. I changed the parameter CephClientKey in ../openstack-tripleo-heat-templates/environment/puppet-ceph-external.yaml  and ran OSPD with the command

# openstack overcloud deploy --templates openstack-tripleo-heat-templates/ -e openstack-tripleo-heat-templates/environments/puppet-ceph-external.yaml .. 

The deployment changed successfully, according to Heat, but the parameter in /etc/ceph/ceph.client... didn't change

Version-Release number of selected component (if applicable):
python-tripleoclient-0.1.1-2.el7ost.noarch
openstack-tripleo-heat-templates-0.8.7-12.el7ost.noarch
openstack-tripleo-common-0.1.1-1.el7ost.noarch
openstack-tripleo-puppet-elements-0.0.2-1.el7ost.noarch
openstack-tripleo-heat-templates-kilo-0.8.7-12.el7ost.noarch
openstack-tripleo-image-elements-0.9.7-2.el7ost.noarch
openstack-tripleo-0.0.7-1.el7ost.noarch


How reproducible:
unknown

Steps to Reproduce:
1. Deploy OSP with external Ceph 
2. Change a parameter in the external ceph environment YAML file
3. Rerun the deployment

Actual results:
The external Ceph user's parameters didn't change

Expected results:
The Ceph client parameters should be updated according to the latest parameters

Additional info:
Comment 2 Mike Burns 2016-04-07 17:11:06 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 4 Giulio Fidente 2016-11-29 15:30:17 EST
I think this bug has been fixed in OSPd10, can we re-test it?
Comment 5 Giulio Fidente 2016-11-29 15:32:17 EST
*** Bug 1361862 has been marked as a duplicate of this bug. ***
Comment 6 Yogev Rabl 2016-12-02 18:50:44 EST
Verification failed in openstack-puppet-modules-9.3.0-1.el7ost.noarch
Comment 11 Tzach Shefi 2017-03-23 08:02:16 EDT
Verified 
puppet-ceph-2.3.0-2.el7ost.noarch

Installed with OSPD with external CEPH yaml file. 
Yaml file included 3 monitor IPs. 
Deployment finished, successfully created a Cinder volume. 
/etc/ceph/ceph.conf included all three monitor IPs. 

Then removed one monitor from CEPH yaml file, left with only two IPs. 
Redeployed overcloud, system finished deployment. 
Cinder create/list works fine. 
/etc/ceph/ceph.conf  now only includes two monitor IPs. 

Lookng great update on yaml file were pushed ceph.conf.
Comment 13 errata-xmlrpc 2017-06-28 10:44:12 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1585

Note You need to log in before you can comment on or make changes to this bug.