Bug 1312769 - Add comment warnings for puppet-managed configuration files
Add comment warnings for puppet-managed configuration files
Status: CLOSED DEFERRED
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-29 04:20 EST by Lukas Zapletal
Modified: 2017-03-27 16:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-27 16:42:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 16255 None None None 2016-08-23 13:33 EDT

  None (edit)
Description Lukas Zapletal 2016-02-29 04:20:37 EST
I've encountered several upgrade errors at customers or redhatters when
DHCP and/or DNS configuration simply disappears after Satellite upgrade.

When our users add or modify subnets or domains, our installer overwrite
the configuration with the initial one. Since our installer is limited 
and only supports definition of one subnet/domain, all the others are 
deleted and users need to restore those configurations from backups.

Purpose of this BZ:

Big warning comments in both /etc/zones.conf and /etc/dhcp/dhcpd.conf
files telling users that upgrade process will rewrite these files. I 
think we already do this upstream. Unfortunately our upstream warning is 
too short IMHO:

### File managed with puppet ###

I think we need to add extra information there for Satellite. In upstream, upgrade process never calls installer again, therefore this short notice is sufficient.
Comment 1 Bryan Kearney 2016-07-26 15:03:20 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 2 Stephen Benjamin 2016-08-23 13:33:24 EDT
Created redmine issue http://projects.theforeman.org/issues/16255 from this bug
Comment 3 Bryan Kearney 2016-08-23 14:13:09 EDT
Upstream bug component is Provisioning
Comment 5 Bryan Kearney 2016-08-24 04:12:55 EDT
Upstream bug component is Installer
Comment 6 Bryan Kearney 2017-03-27 16:42:23 EDT
This bug is being tracked upstream, and will no longer be tracked in the downstream product. When the upstream issue is fixed, the next Satellite release will contain the fix. I am closing this out as deferred. If you feel this is not correct, please feel free to open with additional information.

Note You need to log in before you can comment on or make changes to this bug.